Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2018-04-19 09:37:20



Reply to topic  [ 8 posts ] 
Variregion TPing 
Author Message

Joined: 2014-09-25 22:10:40
Posts: 88
Location: Colorado
Reply with quote
Hello Henri,

So here is the issue. When on a vairregion and I want to TP within that region to another avatars location by using the radar TP to feature, I am whisked away to somewhere else, at a completely different location than where I wanted to go. I enabled the teleport debug tag as you suggested for this issue. Log files are below.

Quote:
Cool VL Viewer v1.26.20.46, 64 bits, Mar 10 2018 10:27:01
Release Notes

CPU: AMD Athlon(tm) II X4 640 Processor (3000.1 MHz)
Memory: 12288MB
OS version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2
Windows graphics driver version: 23.21.0013.9077
OpenGL version: 4.6.0 NVIDIA 390.77
Detected VRAM: 4096MB
J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: FMOD Ex v4.44.64
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3c-(CEF-WIN-3.2526.1347-32)

Built with: MSVC v1800

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMODEX=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


https://drive.google.com/file/d/1lOcCI6 ... sp=sharing

Thanks,
Geoff


2018-03-14 02:26:09
Profile

Joined: 2009-03-17 18:42:51
Posts: 3734
Reply with quote
GeoffEarnshaw wrote:
I enabled the teleport debug tag as you suggested for this issue. Log files are below.
I'm afraid you did not, or sent the wrong log... There's no DEBUG message at all in your log... Make sure to enable the "Teleport" debug flag from "Advanced" -> "Consoles" -> "Debug tags" before teleporting.


2018-03-14 09:22:47
Profile WWW

Joined: 2014-09-25 22:10:40
Posts: 88
Location: Colorado
Reply with quote
Oh sorry about that, I thought I did. :? I'll try again.

Geoff


2018-03-15 15:39:45
Profile

Joined: 2014-09-25 22:10:40
Posts: 88
Location: Colorado
Reply with quote
Sorry for the wait, its been busy every time I get on. I did enable the teleport debug again. Notice it doesn't stay on after a relog.

Code:
Cool VL Viewer v1.26.20.47, 64 bits, Mar 17 2018 11:23:48
Release Notes

You are at 2563200.0, 2558079.9, 24.2  in Undercity located at
dnusa1.dreamnation.net (69.25.198.248:9310)
OpenSim 0.9.1.0 DreamNation dee12accbdeef66be632e880debc65942ca1bfe5 (dirty) 2017-08-26 15:20:53 -0700 (Unix/Mono)

CPU: AMD Athlon(tm) II X4 640 Processor (3000.1 MHz)
Memory: 12288MB
OS version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 1050 Ti/PCIe/SSE2
Windows graphics driver version: 23.21.0013.9077
OpenGL version: 4.6.0 NVIDIA 390.77
Detected VRAM: 4096MB
J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: FMOD Ex v4.44.64
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3c-(CEF-WIN-3.2526.1347-32)
Packets lost: 29/230807 (0.0%)

Built with: MSVC v1800

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMODEX=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


Log files:
https://drive.google.com/file/d/1mmIjry ... sp=sharing

Thanks,
Geoff


2018-03-18 18:13:52
Profile

Joined: 2009-03-17 18:42:51
Posts: 3734
Reply with quote
The problem is that there are 3 teleports in this log (18:04, 18:06, 18:07)... Which one failed ?


2018-03-18 19:09:37
Profile WWW

Joined: 2014-09-25 22:10:40
Posts: 88
Location: Colorado
Reply with quote
The 18:04 and 18:07 ones failed. I discovered that TP'ing within 100 meters works fine, but more than that in a variregion is when things gets interesting.

Geoff


2018-03-19 00:27:30
Profile

Joined: 2009-03-17 18:42:51
Posts: 3734
Reply with quote
OK, it looks like OpenSim var region is so utterly broken that it expects to have the region size ignored (and considered as always being 256m wide) when giving local coordinates for local TPs (using the TeleportLocationRequest UDP message)... Go figure !

BTW, Singularity is also affected by that bug, while Firestorm already figured it out...

Anyway, the "bug will be fixed" (or more exactly, OpenSim's broken implementation will be worked around) in next releases.


2018-03-19 10:27:10
Profile WWW

Joined: 2014-09-25 22:10:40
Posts: 88
Location: Colorado
Reply with quote
Thank you!

Geoff


2018-03-20 16:18:07
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.