Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2020-02-18 00:00:53



Reply to topic  [ 4 posts ] 
Save function for snapshots intermittently grays out 
Author Message

Joined: 2012-08-26 06:18:04
Posts: 12
Reply with quote
Hi Henri,

There is an issue with saving snapshots to disk in the latest version of Cool VL. For some reason, the button will become intermittently grayed out.

Way to reproduce on the Windows version:

1) Launch Cool VL
2) Log into Second Life
3) Press CTRL + SHIFT + S
4) Make sure "Save to your Hard Drive" is selected, if it is not already.
5) Close the snapshot window.
6) Exit and restart Cool VL. Re-log into Second Life
7) Press CTRL + SHIFT + S
8) The "Save" button will be grayed out.

Pressing "Refresh snapshot" may stop it from being grayed out, but if you use the scroll wheel on the mouse to zoom in or out,, it will gray out again.

If you toggle between "Save to your inventory (L$10)" and "Save to your hard drive", it will once again activate the "Save" button, however if you use the scroll wheel on the mouse, it will gray out again.

The "Save As" location has been verified as valid and existing on my hard drive and I have saved snapshots to that location before.

It's kind of an odd thing to have happen.

=======================================================================
Cool VL Viewer v1.26.22.57, 64 bits, Aug 17 2019 11:16:58
RestrainedLove viewer v2.09.25.20
Release Notes

CPU: Intel(R) Core(TM) i5-4590 CPU @ 3.30GHz (3292.38 MHz)
Memory: 16328MB
OS version: Microsoft Windows 10 64 bits v10.0 (build 10586.678)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GT 710/PCIe/SSE2
Windows graphics driver version: Loading...
OpenGL version: 4.6.0 NVIDIA 388.13
Detected VRAM: 1024MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.00.03
Networking backend: libcurl/7.47.0 OpenSSL/1.0.2l zlib/1.2.8
Embedded browser: CEF3 plugin v74.1.19+gb62bacf+chromium-74.0.3729.157

Built with: MSVC v1800
Compiler-generated maths: SSE2.

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMODSTUDIO=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


Attachments:
CoolVLViewerLog.zip [22.85 KiB]
Downloaded 41 times
2019-08-25 04:47:21
Profile

Joined: 2009-03-17 18:42:51
Posts: 4160
Reply with quote
I cannot reproduce this here (tested under Linux and Windows 10), but for the scroll-wheel "issue", which is not an issue at all but the expected behaviour: if you use the scroll wheel while the 3D world view is selected, you change the camera focus and therefore need to refresh the snapshot...

Note that opening the snapshot windows automatically triggers a snapshot refresh anyway, so should it fail on opening (I would suspect a graphics driver race condition in such a case), you can simply rrefresh it manually to get the save button to get un-greyed...


2019-08-26 19:40:03
Profile WWW

Joined: 2012-01-19 03:18:40
Posts: 134
Reply with quote
I only just noticed this thread, so I'm late to the party, but I have experienced this in the OS/X build of Cool VL Viewer. I have had it both with snapshotting to disk (my normal practice), and snapshotting to Inventory. It can be a nuisance when snapping dynamic activities, since refreshing the snap will replace the shot you just made. The only work-around I have found is to use Ctrl-` as a "shutter-release", instead of going through the Ctrl-Shift-S floater, and I have programmed a button on my mouse to issue this shortcut from a middle-button-click.


2020-02-11 23:04:42
Profile

Joined: 2009-03-17 18:42:51
Posts: 4160
Reply with quote
The issue seems to be caused by a race condition where the camera view point slightly changes while the floater is being opened. I personally can barely reproduce it (once in 20 tries or so), but YMMV with various settings (such as camera settings and system speed).

I think I found the solution and so far could not reproduce the issue after implementing it. Will be part of next release.

Oh, I also used the occasion to add an AZERTY keyboards work-around for that stupid CTRL ` shortcut used for snapshots to disk ('`' being a special character, it does not correspond to a non-shifted, non-ALT Gr key for anything but QWERTY keyboards; in AZERTY, it would correspond by its position to the '²' key, so the latter key will now work as an equivalent to the ` key for shortcuts).


2020-02-12 13:43:31
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.