Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-10-19 21:29:29



Reply to topic  [ 30 posts ]  Go to page Previous  1, 2, 3
Region render issue after edit apperance 
Author Message

Joined: 2018-07-14 07:17:42
Posts: 20
Reply with quote
Resetting vertex buffers was the first i tried, it didn't help.

Just now I am on mainland and it happened again, not much different to private estates. Edit appearance, cancel editing appearance, camming out of the house where I am in, more than the half of objects vanished, even more on the neighbor sim. Surprisingly the sim ground is still there :D


2020-06-14 08:12:37
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
What is strange however, is that you mention v1.26.24.18 as the last working version for you... v1.26.24.19 should work the same, since the changes were not already done in it !

Can you please confirm you do see the bug in v1.26.24.19 ?


2020-06-14 08:16:36
Profile WWW

Joined: 2018-07-14 07:17:42
Posts: 20
Reply with quote
I only kept v1.26.24.18, so I thought it started with v1.26.24.19. I will compile v1.26.24.19 and try if it happens for this version.


2020-06-14 08:22:03
Profile

Joined: 2018-07-14 07:17:42
Posts: 20
Reply with quote
I checked now v1.26.24.19 and it starts with this version.


2020-06-14 09:10:54
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
Duncan Armundsen wrote:
I checked now v1.26.24.19 and it starts with this version.

Definitely a different bug, then... Starting to suspect culling changes backported in v1.26.24.19 from Singularity... Will investigate.


2020-06-14 10:08:37
Profile WWW

Joined: 2018-07-14 07:17:42
Posts: 20
Reply with quote
Thank you :)


2020-06-14 10:34:58
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
OK, I think I found the issue... It's about dynamic textures and how I thought LL had the old render target + FBO culling issue resolved (scoop: they did not) when I backported the EE renderer to the viewer (and part of the rendering fixes that came with it, in the Windlight renderer).

But what does it got to do with avatar appearance editing, will you ask ?... Good question !... And the answer is: local bakes and texture previews in the appearance editing floater *are* dynamic textures !...

Yeah, not quite obvious, was it ?... In any case, thanks to the narrowing of the bug introduction to the changes that were done between v1.26.24.18 and v1.26.24.19, I could (relatively) quickly find where the problem came from.

I'd gladly accept a confirmation, if you could apply the following patch to either v1.26.24.22 or v1.27.0.2 sources and compile the viewer:
Attachment:
patch.txt.gz [1.25 KiB]
Downloaded 71 times


2020-06-14 13:08:24
Profile WWW

Joined: 2018-07-14 07:17:42
Posts: 20
Reply with quote
That's it!

I applied the patch to v1.26.24.22 and tried especially the places where it happened always. I don't see this bug anymore.

Thanks a lot!


2020-06-14 15:24:50
Profile

Joined: 2016-06-19 21:33:37
Posts: 237
Location: San Francisco bay area, CA, USA
Reply with quote
Henri Beauchamp wrote:
I'd gladly accept a confirmation, if you could apply the following patch to either v1.26.24.22 or v1.27.0.2 sources and compile the viewer
I have tested with OcclusionPauseDuration set to zero and can also confirm the patch corrects the issue for me (in v1.27.0.2).


2020-06-14 18:19:55
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
Good... Next releases will have the fix. Case closed.


2020-06-14 18:30:02
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 30 posts ]  Go to page Previous  1, 2, 3

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.