Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-04-13 09:59:10



Reply to topic  [ 4 posts ] 
After "Edit Appearance" water stops rendering 
Author Message

Joined: 2013-02-02 22:15:52
Posts: 35
Reply with quote
If I go into "Edit Appearance" then afterwards I can no longer see water in the region I was in when I first edited my appearance. Water renders in other regions, and the void water renders fine. I've tried toggling the various shaders on and off in Preferences - Graphics incase that might reset the missing water but it doesn't help.

It's actually more than the water disappearing, a lot of things under the water vanish too, including the land. As if the water was turned into a giant invisi-prim. But if you physically go underwater, then you can see things that are down there, and you get the dark bluish cast like normal when under water.

Leaving the region and returning does not help, either by crossing to an adjacent region or by teleporting away. The only thing that fixes it is a relog.

About info:
Code:
Cool VL Viewer 1.26.4 (58) Mar 16 2013 08:56:38 (Cool VL Viewer)
Release Notes

You are at 287776.5, 277640.4, 20.6 in Thorklin located at sim10031.agni.lindenlab.com (216.82.48.41:13022)
Second Life RC Magnum 13.03.15.272004
Release Notes

CPU: Intel(R) Core(TM)2 Duo CPU     T7700  @ 2.40GHz (2400 MHz)
Memory: 4096 MB
OS Version: Mac OS X 10.6.8 Darwin 10.8.0 Darwin Kernel Version 10.8.0: Tue Jun  7 16:33:36 PDT 2011; root:xnu-1504.15.3~1/RELEASE_I386 i386
Graphics Card Vendor: ATI Technologies Inc.
Graphics Card: ATI Radeon HD 2600 PRO OpenGL Engine
OpenGL Version: 2.1 ATI-1.6.36

libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8q zlib/1.2.5 c-ares/1.7.1
J2C Decoder Version: OpenJPEG: 1.4.0, Runtime: 1.4.0
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Packets Lost: 252/103963 (0.2%)

Built with GCC version 40001

Compile flags used for this build:
-O2 -fomit-frame-pointer -frename-registers -fweb -fexpensive-optimizations -DNDEBUG -DLL_RELEASE=1 -DLL_RELEASE_FOR_DOWNLOAD=1 -Wall -Wno-sign-compare -Wno-trigraphs -Wno-reorder -Wno-non-virtual-dtor -pipe -g -fexceptions -fno-strict-aliasing -fvisibility-inlines-hidden -fsigned-char -march=pentium4 -msse2 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread -fno-stack-protector -mlong-branch -m32 -DLL_DARWIN=1 -DLL_NEW_HTTP_CORE=1 -DLL_MEDIA_ON_PRIM=1 -DOV_EXCLUDE_STATIC_CALLBACKS -DCARES_STATICLIB -DCARES_STATICLIB -DLIB_NDOF=1


I first noticed this a couple weeks ago, with version 1.26.4.56 but at the time I thought it was an isolated glitch.

Log file and screenshot attached.

Cheers!


Attachments:
File comment: Looking at Thorklin where I edited my appearance, from neighboring Frumatay.
No water, no land under the water.

Screenshot.jpg
Screenshot.jpg [ 33.25 KiB | Viewed 1016 times ]
File comment: Edited appearance around the 2013-03-20T16:50 timestamp
SecondLife.log.zip [32.5 KiB]
Downloaded 88 times
2013-03-20 17:16:59
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Yes, this is a known bug of v2/3 renderers that LL worked around by simply avoiding to ever enter the edit appearance camera mode in their viewers (which also breaks the thumbnail preview in LL's viewer appearance editor).

To get the missing objects rendered again, you have to teleport several sims away (so that the affected sims are no more within draw distance), wait for 2 or 3 minutes (so that the affected sims actually get disconnected and wiped off the viewer memory), then TP back in.

I'll try to investigate this bug and find a better work around than LL's (or possibly a definitive fix), time permitting.


2013-03-20 18:47:07
Profile WWW

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Good news: I found the bug and fixed it for the next releases.

In the mean time, you can disable the "Object Occlusion" setting (in the Hardware sub-floater of the Graphics preferences) whenever the problem occurs (and you can re-enable it once you TPed away from the affected regions).


2013-04-08 22:34:14
Profile WWW

Joined: 2013-02-02 22:15:52
Posts: 35
Reply with quote
That's great news!

Thank you so much Henri!

:D


2013-04-10 12:41:37
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.