Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-04-13 09:50:59



Reply to topic  [ 5 posts ] 
Voice Status Wrong @ InWorldz Grid 
Author Message

Joined: 2013-04-16 00:17:32
Posts: 8
Location: Tennessee, USA
Reply with quote
Using viewer 1.26.6.20 under Windows 7x64.

In InWorldz the status info at the top always shows the icon for "Voice Not Available", although voice works and I can talk/listen to people. The problem does not occur in Second Life. I cross checked with the Singularity, Imprudence and InWorldz viewers and they show correct the status info (that voice is working).

It is not a big problem, more of an annoyance. Not all sims are voice enabled, so you always have to try to see if you can do voice or not.

Please let me know if I can be of any further help investigating that problem.

Wolfe Blackburn


2013-04-16 20:40:46
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Please, follow the rules for this forum and provide the required info and files.


2013-04-16 21:10:38
Profile WWW

Joined: 2013-04-16 00:17:32
Posts: 8
Location: Tennessee, USA
Reply with quote
Henri Beauchamp wrote:
Please, follow the rules for this forum and provide the required info and files.


Sorry, I forgot to attach the log file. Here it is.

Wolfe Blackburn


Attachments:
SecondLife.zip [13.2 KiB]
Downloaded 81 times
2013-04-16 23:27:17
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Apparently, it's a bug in OpenSim (or Inworldz' own flavour of OpenSim).

Normally, voice is available only when both enabled for the region and the parcel (meaning the region owner can disable voice for the whole region via the estate settings, and parcel owners can always disable voice for their own parcel and enable it only when the region owner enabled voice region-wide). At least, this is how it works in SL and this is why the Cool VL Viewer's no-voice indicator appears in the status bar as soon as either the parcel or the region got voice disabled, while most other viewers only rely on the parcel flag...

In Inworldz, the region voice flag is always off regardless of actual voice availability !

I changed the code so that, when logged on an OpenSim grid, only the parcel voice flag is taken into account for the no-voice indicator of the status bar. The fix will be available in the next releases.


2013-04-17 09:11:26
Profile WWW

Joined: 2013-04-16 00:17:32
Posts: 8
Location: Tennessee, USA
Reply with quote
Wow, that was fast! Thank you so much. Me and my friends are using the Cool VL Viewer for some days now - for the most part in InWorldz - and it works really great. Fantastic Work!


2013-04-19 03:00:21
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.