Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-04-13 10:24:01



Reply to topic  [ 19 posts ]  Go to page 1, 2  Next
all three releases (from May11) lock up 
Author Message

Joined: 2011-09-04 21:14:27
Posts: 26
Location: Windsor, Ontario, Canada
Reply with quote
all three releases (from May11) lock up immediately upon login to any grid on me so badly I've had to revert to the last release.

I am hoping the thing you imported from Firestorm was NOT their extremely laggy memory management technique as they use GIANT memory addressing as opposed to system friendly methods.

Note most often the *.4.68 viewer locks up upon ATTEMPTING to log in.

System particulars:
Win XP Pro
AMD Athlon 3500+ (2.2 Ghz) single core
2.75Gig Ram

And NO sales people need to respond "you need to upgrade your hardware" as this is not a gamer machine, it's a BUSINESS TOOL.


2013-05-13 17:31:06
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
No log = no possible investigation. And no, there was no change whatsoever to memory management...


2013-05-13 18:44:09
Profile WWW

Joined: 2011-12-12 04:09:46
Posts: 82
Reply with quote
I have the same problem. Here are my logs.


Attachments:
Crash.zip [14.03 KiB]
Downloaded 101 times
2013-05-14 13:06:40
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Jeeper wrote:
I have the same problem. Here are my logs.
The SecondLife.dmp file is missing and it's what I need to get the stack trace...


2013-05-14 14:16:59
Profile WWW

Joined: 2011-12-12 04:09:46
Posts: 82
Reply with quote
It's not creating SecondLife.dmp. It just freezes with Not responding. Could I have something disabled to prevent it from writing that file?


2013-05-15 01:19:32
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
Jeeper wrote:
It's not creating SecondLife.dmp. It just freezes with Not responding. Could I have something disabled to prevent it from writing that file?

There's the "Advanced" -> "Output Debug Minidump" setting, that must be enabled.. You can also enable it from the login screen via "Advanced" -> "Debug Settings...", then by selecting SaveMiniDump and setting it to TRUE (then close and restart the viewer to make sure this setting will be saved).

Note that the viewer got a watchdog, under Windows, so you should let it close by itself when it freezes, else (i.e. if you remove it with the task manager) it will not core-dump either. The timeout is set via the MainloopTimeoutDefault setting, and the watch dog is enabled when WatchdogEnabled is TRUE.

If the watchdog doesn't trigger, then it's going to be really hard to diagnose... I'll need your settings_coolvlviewer_1264.xml file to try and reproduce this crash here, with your own settings...

You may also try to disable all the shaders (uncheck "Basic shaders") in the Graphics settings, and to disable the VBO usage in the Hardware Options, to see if it's a graphics driver-related crash. What was the last working release for you ? Also, I see you are still using v1.26.4 while your system is quite capable of running v1.26.8: is v1.26.8.4 working fine ?


2013-05-15 11:29:30
Profile WWW

Joined: 2011-12-12 04:09:46
Posts: 82
Reply with quote
I do have "Output Debug Minidump" enabled but it's not creating the dmp file. The timeout is set for the default, I believe 20 seconds. I've left it sit for 5 or 10 minutes. I have also confirmed that the watchdog is enabled. I have disabled the shaders, hardware settings and audio, but that didn't help.

The last version that worked for me was the previous version, 1.26.8.3, 1.26.4.7 and 1.26.9.3.


Attachments:
settings_coolvlviewer_1268.zip [8.47 KiB]
Downloaded 91 times
2013-05-16 00:43:09
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
No joy... I tried your settings file on a 64bits Windows 7 system (close to yours: Core-i5, 8Gb RAM, GTX460), but the viewer started just fine... Another thing you could try on your side is to start with fresh settings (rename the settings_coolvlviewer_1268.xml file to, say, settings_coolvlviewer_1268.xml.mine so to preserve it and restore it later, then log in with v1.26.8.4 and see what happens).

The next step for you to take might sound a bit daunting: it would be to install VS2010 on your system so to be able to "attach" with it to the running instance of the viewer and to interrupt the latter to get the stack trace of the place where the viewer is looping forever...


2013-05-16 08:55:52
Profile WWW

Joined: 2011-12-12 04:09:46
Posts: 82
Reply with quote
I tried fresh settings but no difference. I'll have to do some reading on how to set up VS2010 as I have no clue how to do that atm.


2013-05-16 11:23:01
Profile

Joined: 2009-03-17 18:42:51
Posts: 4559
Reply with quote
You will find the required info in the linden/doc/WindowsBuildHowto.txt file of the viewer sources.

Note that you won't need to install everything listed there (unless you wish to be capable of rebuilding the viewer yourself): just VS2010 is needed for its debugger... There might even be a simpler way (other debugging tools ?), but I'm not a Windows guru (Linux and UNICES guru only :-P).


2013-05-16 12:56:21
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 19 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.