Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-10-19 09:13:35



Reply to topic  [ 2 posts ] 
1.26.8(12)/Windows cannot switch any light source 
Author Message

Joined: 2010-04-07 23:10:41
Posts: 14
Location: Moscow, Russia
Reply with quote
The recent versions of the 1.26.8 viewer for Windows doesn't reflect the changes of the light sources made by the lsl scripts. In other words, one cannot switch on/off any light bulb. How to reproduce: create a prim, put the trivial light bulb script in it (like this one):

Code:
integer on;

default
{
    touch_start(integer dummy)
    {
        on = !on;
        llSetPrimitiveParams([PRIM_POINT_LIGHT, on, <1.0, 1.0, 1.0>, 1.0, 10.0, 0.75]);
    }
}


Then click the prim. Nothing happens. In the Edit window, the Features->Light checkbox is changed in the right way, but there is no light (or no darkness, if you have started from the "light on" state). Releases 1.26.8(11) and 1.26.8(12) for windows are affected, release 1.26.8(9) is unaffected (I have re-installed it from backup to test this).

P.S. Looks like another "broken light bulb" joke, but this is for real. ;-(

Update: 1.26.8 (13) is still affected. The last version without this problem seems to be 1.26.8 (9).


Attachments:
File comment: "broken light bulb" log
broken_light.zip [13.27 KiB]
Downloaded 106 times
2013-06-22 12:35:21
Profile WWW

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
Yes, a silly bug indeed... Fixed for next releases (to be published in a few hours).


2013-06-24 00:38:52
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 2 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.