Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2022-06-28 00:27:46



Reply to topic  [ 20 posts ]  Go to page 1, 2  Next
Viewer not usable after migration to VMM 
Author Message

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
Hello Henri,

Issue:

Only my main AVA with a a big amount of MP articles has the issue after migration to VMM is said to be finished successfully.

The viewer takes about ten minutes to log in (hangs at "Loading World").

When I'm "logged in" finally

- my avi does not show up completely (not only mesh parts and it varies with log in) and I
- cannot move
- cannot tp
- cannot dress or attach anything
- cannot communicate
- my currency does not show up

When I open my inventory the folder "marketplace listings" is marked "fetching" and all folders inside
are marked "updating" - but it does not load even if I leave it for hours.


Things done:

SL Viewer tested - works fine ( but the viewer is a pain ...)
Tried other AVAs - works fine
Tried the old version (1.26.12.49) with my main AVA - works fine.
Several reboots and retries - cleared cache - again no succes with my main AVA and the latest VMM Cool VL Viewer.

Thanks for your help!

About:
Cool VL Viewer 1.26.14 (1) Jul 25 2015 11:12:53 (Cool VL Viewer)
RestrainedLove viewer v2.09.11.20
Release Notes

You are at 218907.0, 319095.2, 651.9 in Desiderium located at sim10030.agni.lindenlab.com (216.82.48.40:13012)
Second Life Server 15.07.16.303633
Release Notes

CPU: Intel(R) Core(TM) i5-3570 CPU @ 3.40GHz (3392.36 MHz)
Memory: 16341 MB
OS version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 650/PCIe/SSE2
Windows graphics driver version: 9.18.0013.4448
OpenGL version: 4.4.0 NVIDIA 344.48

J2C decoder: KDU
Audio driver: FMOD Ex 4.44.55
Networking backend: libcurl/7.38.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: Qt Webkit v4.7.1 (version number hard-coded)
Packets lost: 0/231 (0.0%)

Built with MSVC version 1600

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /arch:SSE2 /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0501 /D_WIN32_WINNT=0x0501 /DLL_PRIVATE_MEMORY_POOLS=1 /DLL_VB_MEM_POOL=1 /DLL_VOLUME_MEM_POOL=1 /DCARES_STATICLIB /DLIB_NDOF=1


2015-07-31 19:02:45
Profile

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
logs


Attachments:
File comment: logs
log.zip [48.31 KiB]
Downloaded 139 times
2015-07-31 19:04:48
Profile

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
Looking at the log, there are 404 errors everywhere: verify that your Windoze firewall is not blocking the viewer (since it installs as a new version, the old authorization for the v1.26.12 won't count)...


2015-07-31 19:37:23
Profile WWW

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
Windows firewall is not enabled.

I'm using Kaspersky and I already disabled Kaspersky. No change.
btw. It works with other AVAs on the same version.
Only the AVA with the large MarketPlace store shows the issues.
First log in with SL viewer took also a while. But it showed progess and worked fine after some minutes.
Now the log in time is normal and no issues at all. But Cool VL Viewer seems to be unable to hanlde it.


2015-07-31 21:12:12
Profile

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
Try clearing the in cache (so to delete the cached inventory files, that could be corrupted after all these 404 errors).

If this fails, before logging in, enable the "Marketplace" debug tag (in "Advanced" -> "Debug tags" menu), then login and let the viewer run a while, then close it and post the log here.

Also, are you running behind a router (especially a WiFi one) ?... If yes, try without the router (those so-called WiFi routers are often unable to handle more than a couple dozens of circuits, when the viewer can use 100 or more...).


2015-07-31 21:27:10
Profile WWW

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
Router is a Draytek 2910 - no WIFI - Lan cable is connected. Believe me the router is rock solid and can handle a lot of connections.

Clearing the cache didn't solve the issue.

Find attached the logs requested...

Thanks for your help.

Btw. a AVA with a little MP store works without problems.

It seems that the issue is the size of the store (more than 2000 products - I'm talking about folders - each folder with 6-15 items).

But again the Secondlife Viewer doesn't show issues. It just works fine. But the interface of the original viewer is just pain in the ass :-(


Attachments:
File comment: debug logs
logs.zip [38.58 KiB]
Downloaded 138 times
2015-07-31 23:30:52
Profile

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
There is no debug info at all (you did not enable the Marketplace debug tag: this very action would be logged if you did). I'm still seeing problems with capabilities (SL server URLs) not being reachable, so no surprise the market place doesn't work. But I still need more info, and only the debug messages can give it.


2015-08-01 00:17:38
Profile WWW

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
I'm sure that I enabled it. Nevertheless will try again later and send it again.


2015-08-01 09:54:30
Profile

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
nofu nagy wrote:
I'm sure that I enabled it. Nevertheless will try again later and send it again.
Perhaps did you post the wrong log...

Also, you did not reply my question: do you run the viewer behind a router (especially a WiFi one) ?

I just uploaded new releases: try v1.26.14.2 and see if it fares better for you. In case of problems, you can also disable Marketplace initialization in this version, by setting "MarketplaceDisabled" to TRUE (before loging in).

Finally, the main difference between LL's VMM viewer and the Cool VL Viewer is that the latter unconditionally attempts to initialize the Marketplace on login, while the former waits for you to open the Marketplace floater: what happens when you do open it, in LL's viewer (are you seeing the same issues as with the Cool VL Viewer or not) ?


2015-08-01 11:01:43
Profile WWW

Joined: 2012-09-26 00:30:35
Posts: 20
Reply with quote
I answered the router question - see my post above: The route is a Draytek 2910 - lan cable is connected
The router can handle a massive amount of connections - believe me.

Installed the latest version: 1.26.14.2
Cleared the cache
Enabled marketplace debug tag

First start took again a while (Loading World...)
Error message after a while: The transaction with the Marketplace failed with the following error: Reason: 'STATUS_EXPIRED'
MP folder shows: fetch failed
After that the viewer started to download the inventory and it looked better than before (AVA is not a cloud - moving is possible)
BUT after I tried to check marketplace folder the viewer crashed.

Second start - Viewer failed to log in after a couple of minutes.

Third start took again a long time with "Loading World" again the MP error message.
The inventory starts to load again.
As I tried "check for errors" the viewer crashed again.

and so on...

Conclusion: It takes a long time to log in. Then after a long time the error message (transaction with the Marketplace...) comes up
and the folder shows "fetch failed".
After that I can use the viewer BUT if it try anything with the marketplace folder: crash.

I have now disabled the mp with your new debug setting. Inventory is loading again...

LL's VMM viewer: No, I have no issues with this viewer. It starts quickly. Evertyhing works fine. When I open the Marketplace floater it takes about 10 seconds
and it shows everything. All folders are there and I can work with them. No issues!


Attachments:
File comment: logs from today
logs_1_8_2015.zip [63.59 KiB]
Downloaded 139 times
2015-08-01 19:21:56
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 20 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.