Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-10-28 05:22:32



Reply to topic  [ 3 posts ] 
OpenSim world map tiles only load on click 
Author Message

Joined: 2016-05-02 10:19:52
Posts: 1
Reply with quote
Hi there, Henri.
I've found that regions in some OpenSim grids only load their respective world map tiles after I click on or search for them. I tested this on OSGrid, Mobius Grid and 3rd Rock Grid - only the last works normally, as these linked screenshots show:

OSGrid
Mobius Grid
3rd Rock Grid

To be thorough, I also checked the grids in Singularity and Alchemy, and there were no issues.

However, this might not just be a Cool VL Viewer problem. Seems that 3RG runs on OpenSim v0.8, while OSGrid and Mobius are on dev branch v0.9 - which was first released late last year, and the map bug started happening around then. Coincidence or not, I don't have the skills to look into it further, so hopefully you can figure it out.


Quote:
Cool VL Viewer 1.26.18 (3) Apr 23 2016 10:11:46 (Cool VL Viewer)
Release Notes

You are at 768132.2, 768002.3, 41.4 in Green Hill Zone located at (64.71.74.173:11398)
OpenSim 0.9.0.0 Dev (Unix/Mono)

CPU: Intel(R) Core(TM) i7-4510U CPU @ 2.00GHz (2593.98 MHz)
Memory: 8076 MB
OS version: Microsoft Windows 8 64-bit (Build 9200) compatibility mode. Real version: 10.0 (Build 10011)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce 820M/PCIe/SSE2
Windows graphics driver version: 10.18.0015.4256
OpenGL version: 4.5.0 NVIDIA 353.54

J2C decoder: KDU
Audio driver: FMOD Ex 4.44.61
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: QtWebkit plugin v2.02.84976 (QtWebKit version 4.7.1)
Packets lost: 0/7577 (0.0%)

Built with MSVC version 1600

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /arch:SSE2 /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0501 /D_WIN32_WINNT=0x0501 /DXML_STATIC /DLL_PRIVATE_MEMORY_POOLS=1 /DLL_VB_MEM_POOL=1 /DLL_VOLUME_MEM_POOL=1 /DBOOST_ALL_NO_LIB /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


Attachments:
CoolVLViewer.log.zip [18.09 KiB]
Downloaded 148 times
2016-05-02 15:28:49
Profile

Joined: 2009-03-17 18:42:51
Posts: 4754
Reply with quote
No bug there, but indeed another undocumented peculiarities of OpenSim grids: their sim coordinates go beyond the normal range found in SL and therefore require an adapted code.

I backported Singularity's changes to the world map block fetches for the next Cool VL Viewer releases...


2016-05-02 20:21:06
Profile WWW

Joined: 2016-04-09 21:27:56
Posts: 2
Reply with quote
I have the same problem. Great to see a solution will come and I can start using my favourite viewer again :) My guess is that the same thing also caused the TP problems I had using Cool VL viewer, newer versions
"edited" unfortunately tp in osgrid is still not going well and in addition I now notice that also the centre titel gets awfull behind in showing the parcel one is on. Sometimes it takes many minutes before it updates to the right parcel.luckily it does show right when I open "About land".
Also VAR regions only show the left-down-corner-region and not the total var in worldmap.
I will try using cool viewer in a few months again as it still remains my favourite layout (UI)viewer. I hope it gets back to its old great working again. Keep up the good work.


2016-05-06 09:52:21
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.