Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-12-16 16:47:27



Reply to topic  [ 8 posts ] 
Member of Too Many Groups 
Author Message

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
So it appears the latest version has a bug in allowing to join a group in Opensim in DreamNation. Other people that used Cool VL a few versions ago had the same problem that they couldn't join groups regardless of the number of groups they had. I think two versions ago it was fixed as I could join groups regardless of the number of groups I had and when they upgraded to that version they could also. I had to use FS to join the group in question. :(

Attachment:
TooManyGroups.jpg
TooManyGroups.jpg [ 29.07 KiB | Viewed 295 times ]

Code:
Cool VL Viewer 1.26.18.29 Oct 22 2016 10:43:19 (Cool VL Viewer)
Release Notes

CPU: Intel(R) Core(TM) i7-6700HQ CPU @ 2.60GHz (2591.98 MHz)
Memory: 16261 MB
OS version: Microsoft Windows 8 64-bit  (Build 9200) compatibility mode. Real version: 10.0 (Build 10586)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 970M/PCIe/SSE2
Windows graphics driver version: OpenGL version: 4.5.0 NVIDIA 372.54

J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: FMOD Ex v4.44.63
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3c-(CEF-WIN-3.2526.1347-32)

Built with MSVC version 1800

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_FMODEX=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1



Geoff


2016-10-24 16:42:05
Profile

Joined: 2009-03-17 18:42:51
Posts: 3655
Reply with quote
The group code did not change in many, many months, so if it used to work for you, it should keep working, or it's something to do with the grid itself (the maximum number of group is provided by the grid on login, and the Cool VL Viewer then abides by it, or uses a default number).

In any case, since you don't provide a log, I cannot diagnose what is the reason for your issue...


2016-10-24 23:53:02
Profile WWW

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
OK, so I never looked up the logs before and hope I came across the right ones. However, the zip size is too big to upload here. Therefore I had to upload it to Google Drive.. https://drive.google.com/file/d/0B9sV-i ... sp=sharing

If this is not the log files you need, please let me know and I will hunt down the correct files.

Geoff


2016-10-25 15:32:00
Profile

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
Ok never mind.. There apparently was a glitch yesterday when receiving the invite. Today I am able to join groups. I should have re-logged yesterday and tried again, which I usually do. So sorry to bother you!

Geoff


2016-10-25 15:58:33
Profile

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
I'm sorry, but it does seem this is an issue with joining groups, since the new version you released yesterday with better logging, maybe you can see if there is an issue?

https://drive.google.com/file/d/0B9sV-i ... sp=sharing


Geoff


2016-10-30 21:18:20
Profile

Joined: 2009-03-17 18:42:51
Posts: 3655
Reply with quote
The explanation is here:
Code:
2016-10-30T19:58:56Z INFO: LLStartUp::idleStartup: gMaxAgentGroups read from login.cgi: 0

So, apparently, the grid wrongly returns 0 as the maximum number of groups on login !... I'll have to add a check for such a silly case, but it should not be happening at all: the grid is obviously misconfigured !

I also notice that you got crashes (CoolVLViewer.dmp files): this should not happen ! Please file a bug report for the cases that make the viewer crash (the crash is unrelated to the group issue, so please, open another topic for it).

Your network, or your network route to the grid, or the grid services themselves also seems quite flaky, with a lot of out-of-order UDP packets reported in the log, as well as 404 errors for assets that should exist, and invalid responses from sim server. If I were you, I'd check with the grid admins to see what's going wrong on their side...
Code:
2016-10-30T19:59:12Z WARNING: LLMeshHeaderHandler::processFailure: Error during mesh header handling. ID: 62ba5f99-fd88-a93a-aa6f-11d340d49f81 - Reason: Not Found (Http_404). Not retrying.
2016-10-30T19:59:12Z WARNING: LLMeshHeaderHandler::processFailure: Error during mesh header handling. ID: d575c81c-fa33-985d-21bd-f1b44d6868a4 - Reason: Not Found (Http_404). Not retrying.
2016-10-30T19:59:12Z WARNING: LLMeshHeaderHandler::processFailure: Error during mesh header handling. ID: 3121902c-73b1-2a07-7273-520dd0c7e848 - Reason: Not Found (Http_404). Not retrying.
2016-10-30T19:59:12Z WARNING: LLMeshHeaderHandler::processFailure: Error during mesh header handling. ID: bb5cda18-9777-3b29-d600-33b74cca44c0 - Reason: Not Found (Http_404). Not retrying.
2016-10-30T19:59:12Z WARNING: LLMeshHeaderHandler::processFailure: Error during mesh header handling. ID: dc6ec85b-9375-6048-0fcf-b6056320a389 - Reason: Not Found (Http_404). Not retrying.
.../...
2016-10-30T19:59:22Z WARNING: LLTextureFetchWorker::onCompleted: Texture: d004ae89-e585-4282-99fd-2c82db828cda CURL GET FAILED, status: Http_404 - reason: Not Found
.../...
2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <7> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa2.dreamnation.net:9180/CAPS/EQG/4b94a767-3ccb-4827-8e1a-55fe6c0f7b41/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>

2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <5> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa1.dreamnation.net:9182/CAPS/EQG/43f0e9c3-f74b-45a9-a151-951faee799c5/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>

2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <4> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa1.dreamnation.net:9185/CAPS/EQG/b61532dd-ef03-4844-a279-46a56cf1dcd6/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>

2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <3> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa2.dreamnation.net:9130/CAPS/EQG/ea543ed8-74d6-49a5-829b-74f50f75fbd8/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>

2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <6> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa3.dreamnation.net:9145/CAPS/EQG/509de35b-a9b0-4198-8dc4-a6c41ccb8027/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>

2016-10-30T20:06:51Z WARNING: LLEventPollImpl::eventPollCoro: Event poll <8> received without event or id key: <llsd><map><key>http_result</key><map><key>headers</key><map /><key>message</key><string /><key>status</key><integer>0</integer><key>success</key><boolean>1</boolean><key>type</key><integer>200</integer><key>url</key><string>http://dnusa1.dreamnation.net:9214/CAPS/EQG/d8358a4c-2169-4c2c-af1c-b843136880ff/</string></map><key>login</key><string>false</string><key>message</key><string>No handler registered for LLSD Requests</string><key>reason</key><string>LLSDRequest</string></map></llsd>
.../...
2016-10-30T20:07:15Z INFO: LLCircuitData::checkPacketInID: Packet out of order - got packet 47094 expecting 46974 from 69.25.198.248:9119
2016-10-30T20:07:15Z INFO: LLCircuitData::checkPacketInID: Packet out of order - got packet 1196 expecting 552 from 69.25.198.248:9135
2016-10-30T20:07:15Z INFO: LLCircuitData::checkPacketInID: Packet out of order - got packet 47593 expecting 47096 from 69.25.198.248:9119
2016-10-30T20:07:15Z INFO: LLCircuitData::checkPacketInID: Packet out of order - got packet 2289 expecting 1202 from 69.25.198.248:9135
2016-10-30T20:07:15Z INFO: LLCircuitData::checkPacketInID: Packet out of order - got packet 2679 expecting 2293 from 69.25.198.248:9135


2016-10-30 23:51:33
Profile WWW

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
Aww that actually doesn't surprise me. If you could just see the sim log files, you would pull your hair out. I'll check with the Admin and see if it would be ok for me to post it here.Thats if you want to see it.

Everyone crashes in DN, its been the norm of things, especially when TP'ing to another sim or if the sim has a 10 or more avatars on it, or even crashing for no other reason. We all thought this was related to OS 0.9 when we upgraded earlier this year; that we thought was a buggy OS.

I will submit a new bug report for the crashes. Thanks!

Geoff


2016-10-31 15:29:04
Profile

Joined: 2014-09-25 22:10:40
Posts: 72
Location: Colorado
Reply with quote
I notified our Tech and he changed the settings for groups to 128. He said he did have them set a while back ago to 100 but something must have happened when we upgraded the OS or applied a patch which reverted the group settings to 0.

Also, the grid is being upgraded to the newest patches tonight. Hopefully that will solve many issues.

Geoff


2016-10-31 23:05:34
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.