Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2022-01-21 19:58:19



Reply to topic  [ 9 posts ] 
Auto Reply Not Working 
Author Message

Joined: 2019-12-13 12:01:19
Posts: 10
Reply with quote
For the last few viewers updates the auto reply doesn't work. The only person that can see the auto reply when i have it enabled is my alt. It doesn't work on busy or away either.

Cool VL Viewer v1.26.24.12, 64 bits, Mar 21 2020 12:51:10
Release Notes

CPU: Intel(R) Core(TM) i9-9900K CPU @ 3.60GHz (3600 MHz)
Memory: 32688MB
OS version: Microsoft Windows 10 64 bits v10.0 (build 10586.720)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce RTX 2060 SUPER/PCIe/SSE2
Windows graphics driver version: Loading...
OpenGL version: 4.6.0 NVIDIA 442.74
Detected VRAM: 8192MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.00.08
Networking backend: libcurl/7.47.0 OpenSSL/1.0.2l zlib/1.2.8
Embedded browser: CEF3 plugin v74.1.19+gb62bacf+chromium-74.0.3729.157

Built with: MSVC v1916
Compiler-generated maths: SSE2.

Compile flags used for this build:
/O2 /Oi /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMODSTUDIO=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


Attachments:
zipped.zip [19 KiB]
Downloaded 103 times
2020-03-21 20:13:45
Profile

Joined: 2009-03-17 18:42:51
Posts: 4809
Reply with quote
The log you attached does not even show the opening of an IM session... hard to diagnose the issue without it !

In any case, auto-reply works fine for me, so you will have to be more precise/explicit, and describe how you configured the viewer for IM and chat (a screen shot of the IM preferences would do)...


2020-03-21 21:55:45
Profile WWW

Joined: 2019-12-13 12:01:19
Posts: 10
Reply with quote
Sorry can't get it to zip the file for some reason https://gyazo.com/d1b0bccb7ebbbf5e8f99c8d7302f163a


2020-03-22 06:40:48
Profile

Joined: 2019-12-13 12:01:19
Posts: 10
Reply with quote
carrieboo wrote:
Sorry can't get it to zip the file for some reason https://gyazo.com/d1b0bccb7ebbbf5e8f99c8d7302f163a

I had the auto reply on all afternoon and everyone the IM'd me i asked if saw it and they said no.


2020-03-22 06:52:51
Profile

Joined: 2009-03-17 18:42:51
Posts: 4809
Reply with quote
Hmm... I think I found the issue. What happens if you un-check "Open new IM session as soon as someone starts typing to you" ?


2020-03-22 08:27:46
Profile WWW

Joined: 2019-12-13 12:01:19
Posts: 10
Reply with quote
I unchecked it as soon as someone IM'd me and they still never got the auto reply message.


2020-03-22 08:42:20
Profile

Joined: 2009-03-17 18:42:51
Posts: 4809
Reply with quote
carrieboo wrote:
I unchecked it as soon as someone IM'd me and they still never got the auto reply message.
No auto-reply does not work like this. You must first un-check "Open new IM session as soon as someone starts typing to you" (and keep it disabled), close any existing IM session, then have them IMing you. The auto-reply is sent when a new message is received and no session (i.e. no corresponding IM tab) currently exists with the person IMing you.

I don't use this early session opening feature myself, but could confirm here that when enabled it breaks auto-reply (since the session gets opened, and when the first IM arrives, the code sees a session already exists, and consequently does not trigger auto-reply). A fix is ready for next release.


2020-03-22 09:05:38
Profile WWW

Joined: 2019-12-13 12:01:19
Posts: 10
Reply with quote
Thank you very much for that Henri.


2020-03-22 09:07:44
Profile

Joined: 2009-03-17 18:42:51
Posts: 4809
Reply with quote
Fixed in today's release.

I had two options to fix the issue with "Open new IM session as soon as someone starts typing to you" enabled:
  • Send the auto-reply as soon as the resident starts typing to you while you are in Away/Busy/Auto-reply mode.
  • Do not open the IM session tab early when they start typing to you and you are in Away/Busy/Auto-reply mode.

Since I found the first solution quite a bit "aggressive" towards people IMing you, I chose the second option.


2020-03-28 09:26:10
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 9 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.