Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-10-20 16:48:01



Reply to topic  [ 6 posts ] 
Received Objects Going Into Texture Folder 
Author Message

Joined: 2010-03-27 04:10:24
Posts: 11
Reply with quote
I upgraded this morning to the latest and greatest experimental branch version, Cool VL Viewer v1.27.0.3 . I went out and got some group gifts and lucky panel gifts. The objects I received went directly into the Textures folder, rather than the Objects folder.

Thanks for all your hard work, and any and all help!

Computer info:
CPU: Intel(R) Core(TM) i7-9750H CPU @ 2.60GHz (2592 MHz)
Memory: 8044MB
OS version: Microsoft Windows 10 64 bits v10.0 (build 10586.900)
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 1650/PCIe/SSE2
Windows graphics driver version: 26.20.0100.7584
OpenGL version: 4.6.0 NVIDIA 445.75
Detected VRAM: 4096MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.01.01
Networking backend: libcurl/7.47.0 OpenSSL/1.0.2l zlib/1.2.8
Embedded browser: CEF3 plugin v74.1.19+gb62bacf+chromium-74.0.3729.157
Packets lost: 76/16191 (0.5%)

Built with: MSVC v1916
Compiler-generated maths: SSE2.

Compile flags used for this build:
/O2 /Oi /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMOD=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


2020-06-21 21:02:33
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
You failed to provide a log, and I cannot reproduce any such issue here (tested with 3 avatars and several notices with attachments sent to groups they pertain to)...

Next time you get a notice and the gift arrives in a wrong folder, do post the log.

Oh, also, do NOT use the "Advanced" -> "Network" -> "Use capability for offline IMs retrieval". It has been months LL has been trying to make it work, but it is still utterly broken !


2020-06-21 22:04:51
Profile WWW

Joined: 2016-06-19 21:33:37
Posts: 237
Location: San Francisco bay area, CA, USA
Reply with quote
I have experienced this today as well. The objects were the 'swaginator' gifts from the SL17B hunt. All items ended up in the Textures folder. I have relogged numerous times since then, but I'll capture logs the next time it happens for me.


2020-06-21 22:47:36
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
OK, found the culprit: it's the changed logic LL implemented last week in an attempt to fix their capability-based offline IMs retrieval code, and that I backported with too much enthusiasm/hope.

Note that this does NOT apply to offline IMs gifts (thus why I could not reproduce it with group IMs), but to objects given by scripted objects.

This will be reverted in next release.

If you compile the viewer yourself, you may revert (with 'patch -p1 -s -R <path-to-patch/bogus_im_patch.txt' from inside the linden/ directory of the sources) this patch:
Attachment:
bogus_im_patch.txt [3.79 KiB]
Downloaded 69 times


2020-06-22 19:25:36
Profile WWW

Joined: 2010-03-27 04:10:24
Posts: 11
Reply with quote
I checked "Advanced" -> "Network" -> "Use capability for offline IMs retrieval" and it was not selected (no "x" next to the menu item.


2020-06-22 23:27:38
Profile

Joined: 2016-06-19 21:33:37
Posts: 237
Location: San Francisco bay area, CA, USA
Reply with quote
Henri Beauchamp wrote:
OK, found the culprit: it's the changed logic LL implemented last week in an attempt to fix their capability-based offline IMs retrieval code, and that I backported with too much enthusiasm/hope.

Note that this does NOT apply to offline IMs gifts (thus why I could not reproduce it with group IMs), but to objects given by scripted objects.

This will be reverted in next release.

If you compile the viewer yourself, you may revert (with 'patch -p1 -s -R <path-to-patch/bogus_im_patch.txt' from inside the linden/ directory of the sources) this patch:
Attachment:
bogus_im_patch.txt

Thanks for the patch, Henri. I applied it to my build last night and can confirm that 'standard' behavior is restored.


2020-06-23 12:51:16
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.