Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2022-12-08 07:11:29



Reply to topic  [ 3 posts ] 
[1.30x] [AMD Linux] Deferred Rendering Unavabile. 
Author Message

Joined: 2021-11-18 08:47:57
Posts: 7
Reply with quote
Greetings!
As of the switch to 1.30x (1.29 worked before) it seems to be impossible to have the deferred rendering mode enabled.
Currently tested with: v1.30.0.2
The viewer hangs for a brief second, like it uses to when your GPU is unable to support the shader mode (i.e. too old)
Only related errors i see regarding this in the log are as follows:
2022-06-11 20:53:41Z WARNING: LLShaderMgr::loadShaderFile: GLSL compilation error: 0 - Shader file: deferred/materialF.glsl
2022-06-11 20:53:41Z WARNING: LLShaderMgr::loadShaderFile: Failed to load deferred/materialF.glsl
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to map attributes for: Deferred material shader 1
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to map uniforms for: Deferred material shader 1
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to link using shader level 1 trying again using shader level 0
2022-06-11 20:53:41Z WARNING: LLShaderMgr::loadShaderFile: GLSL Shader file not found: deferred/materialV.glsl
2022-06-11 20:53:41Z WARNING: LLShaderMgr::loadShaderFile: GLSL Shader file not found: deferred/materialF.glsl
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to map attributes for: Deferred material shader 1
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to map uniforms for: Deferred material shader 1
2022-06-11 20:53:41Z WARNING: LLGLSLShader::createShader: Failed to link shader: Deferred material shader 1

Used System is: CPU: AMD Ryzen 7 2700 Eight-Core Processor (1377.4 MHz)
Memory: 64250MB
OS version: Linux-x86_64 v5.19.0-rc1-x86_64 #1 SMP PREEMPT_DYNAMIC Tue Jun 7 05:34:39 CEST 2022
Memory manager: jemalloc v5.3.1-20220520
Graphics card vendor: AMD
Graphics card: AMD Radeon RX 5700 XT (navi10, LLVM 14.0.4, DRM 3.47, 5.19.0-rc1-x86_64)
OpenGL version: 4.6 (Compatibility Profile) Mesa 22.2.0-devel (git-d64fbb8886)
Detected VRAM: 7116MB
but i am also able to reproduce this same issue on:
Graphics card: AMD Custom GPU 0405 (vangogh, LLVM 14.0.4, DRM 3.47, 5.19.0-rc1-x86_64)
OpenGL version: 3.0 Mesa 22.2.0-devel (git-893b4d98f8)
- I am not sure on how to further debug this than assuming either mesa is being troublesome or something with the viewer code.
Just ruling out mesa as i tried it again with Mesa 22.1.1, same issue. Nor does work with Zink(opengl to vulkan) So maybe amdgpu... But the same occurs when using llvmpipe (software/ llvmpipe (LLVM 14.0.4, 256 bits) opengl 4.5)


2022-06-11 21:24:20
Profile

Joined: 2009-03-17 18:42:51
Posts: 5100
Reply with quote
Copy-paste bug in v1.30.0.2... Line 236 of app_settings/shaders/class1/deferred/materialF.glsl, change to read:
Code:
#else
    if (diffcol.a < minimum_alpha)
#endif
I.e. remove the "-bias" in that line...

I will publish a fixed release tomorrow.


2022-06-12 00:04:20
Profile WWW

Joined: 2009-03-17 18:42:51
Posts: 5100
Reply with quote
This problem (as well as another, in the same shader file) has been fixed in v1.30.0.3 I just released. Please update to the latter.


2022-06-12 08:22:13
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.