Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-06-28 05:28:32



Reply to topic  [ 4 posts ] 
Frequent Crashing in v1.25.0.17 (nickname highlighting?) 
Author Message

Joined: 2010-12-19 23:52:04
Posts: 4
Reply with quote
login via link, runs for a few seconds to a few minutes... setting busy mode seems to slow it down, and looking at the log it may be in the name highlighting feature, which was empty in my setup due to an early crash wiping changes.... may be being triggered by zf(Red Zone), which probably uses the im typing stop among other things....

Quote:
Cool VL Viewer 1.25.0 (17) Dec 10 2010 15:48:29 (Cool VL Viewer)
RestrainedLove viewer v1.25b (Cool VL Viewer v1.25.0)
Release Notes

Built with MSVC version 1400

You are at 248680.6, 243316.0, 24.7 in Whitmyre located at sim3976.agni.lindenlab.com (216.82.4.142:12035)
Second Life Server 10.11.30.215699
Release Notes

CPU: Intel Core 2 Series Processor (2400 MHz)
Memory: 2815 MB
OS Version: Microsoft Windows XP Service Pack 3 (Build 2600)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 280/PCI/SSE2
Windows Graphics Driver Version: 6.14.0011.9062
OpenGL Version: 3.1.0

libcurl Version: libcurl/7.19.6-CVS OpenSSL/0.9.8j c-ares/1.6.0
J2C Decoder Version: KDU
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.5.2
Packets Lost: 0/1184 (0.0%)


Last edited by Void on 2010-12-23 23:06:12, edited 1 time in total.



2010-12-20 00:14:47
Profile

Joined: 2009-03-17 18:42:51
Posts: 3583
Reply with quote
Alright... You know, I'm still trying to figure out what you mean here... Please, write plain and explicit phrases (with a subject, a verb, and a complement) and give precise repro steps... I'm going to try and *guess* what you meant:

Void wrote:
login via link, runs for a few seconds to a few minutes... setting busy mode seems to slow it down,
Setting yourself to "busy" doesn't slow down anything... However, if you let the viewer window loose the focus (which is likely to happen if setting yourself busy was done so that you could deal with other stuff in another program window) then the viewer enters its low frame rate mode (the viewer voluntarily slows down its refresh rate to alleviate the load on the CPU, so that you can do other stuff while staying logged in SL). This is not a bug, or (if you didn't loose the focus when the slow down happened) I cannot reproduce it.

Quote:
and looking at the log it may be in the name highlighting feature, which was empty in my setup due to an early crash wiping changes....
Even if the list of nicknames is empty, the list of words to highlight should at the very least contain your avatar's first name (for newly registered avatars, it's the user name) and last name (for older residents only, since for new ones this name is "Resident" and not taken into account). So, the strange thing is that the log says that the list is empty. In fact, winding back to your first three words "login via link" I supposed you meant that the viewer was launched after you clicked on a slurl in your web browser... so, I did the same thing and indeed, doing so (which means using the --autologin command line option of the viewer) results in the FirstName and LastName settings *not* being set, resulting, when the nicknames list is also empty, in an empty list of words to look for, which in turn triggers the crash (since the list normally contains at least one word, the avatar first name, no check is done for an empty list).

Quote:
may be being triggered by zf(Red Zone), which probably uses the im typing stop among other things....
I've not the tiniest clue of what you are speaking about here... But nevermind, since I spotted the bug and it will be fixed in the next release.


2010-12-22 10:00:21
Profile WWW

Joined: 2010-12-19 23:52:04
Posts: 4
Reply with quote
I was thinking the highlighter might have been loading in once the first IM (or chat) was received (hence busy mode stopping IM's)... the system mentioned uses IM's from bots on a cycle

the shortcut link used includes --login, so yeah.

since we're on start parameters, is there a correct format for using --Grid that will allow selection of SL beta (aditi)? it doesn't like the space in SecondLife Beta, and doesn't recognize it without, or using aditi (obviously).

PS
thanks for all the work on the viewer, very nicely done.


2010-12-23 23:05:22
Profile

Joined: 2009-03-17 18:42:51
Posts: 3583
Reply with quote
The crash bug has been fixed in today's release (v1.25.0.18).

As for the --grid option, it was more or less broken in Snowglobe (on which the Cool VL Viewer v1.25.0 is based) as a result of how the login names and passwords are now saved independently and for each grid. I might have a look at this issue, but it is for now low priority for me since I'd rather work on more important matters in the coming weeks (namely: mesh support).


2010-12-24 16:41:10
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.