Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-10-18 20:31:08



Reply to topic  [ 6 posts ] 
Rigged Mesh Display Bug 
Author Message

Joined: 2012-02-09 21:01:50
Posts: 284
Reply with quote
See small video here. Some parts are flickering to another location about 1m away from the avatar.

http://xp2.de/tillie/meshbug/

Version Info:

Cool VL Viewer 1.26.4 (3) Mar 10 2012 14:41:34 (Cool VL Viewer)
RestrainedLove viewer v2.08.03.21

Second Life Server 12.02.24.249991

CPU: Intel(R) Core(TM) i7 CPU 860 @ 2.80GHz (2808.76 MHz)
Memory: 8184 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 460/PCI/SSE2
Windows Graphics Driver Version: 8.17.0012.8562
OpenGL Version: 4.2.0

libcurl Version: libcurl/7.20.1 OpenSSL/0.9.8j zlib/1.2.3
J2C Decoder Version: KDU
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Packets Lost: 194/209456 (0.1%)


2012-03-17 15:50:39
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
Please, stop reporting bugs that already have been reported in the JIRA for the official viewer... It's of no use at all !

This bug is described in SH-3013. It will be fixed when LL fixes it !


2012-03-17 16:09:48
Profile WWW

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
In fact, I investigated further and found out that the bug happened much more often in v1.26.4 than in v1.26.2 (in the latter, it only happens sometimes, when caming around, just like in all v2/3 viewers)... and the problem comes from the mesh deformer code (which was not implemented in v1.26.2). I got a workaround ready for the upcoming v1.26.4.5 release, and I reported the bug on Qarl's blog.


2012-03-21 00:11:07
Profile WWW

Joined: 2012-02-09 21:01:50
Posts: 284
Reply with quote
Yay! :D Thank you.


2012-03-22 12:22:41
Profile

Joined: 2009-03-17 18:42:51
Posts: 4751
Reply with quote
The workaround for this glitch has been implemented in v1.26.4.5.

This glitch is actually due to rigged mesh attachments rebuilds: it still exists (in all mesh viewers) and can still be seen happening, sometimes, when zooming in/out (LOD changes trigger rigged mesh attachments rebuilds) and during rigged mesh initial rezzing (see SH-3013).

The work-around I implemented simply consists in not rebuilding rigged meshes every few frames as long as you have the Mesh Deformer disabled in your viewer or, when you have it enabled, as long as the avatars wearing rigged meshes do not use any deformer-ready mesh.
It means that if an avatar wears a deformer-ready rigged mesh attachment and you have mesh defomer active in your viewer, you may still see rigged meshes "jumping" on that avatar (and only on that one) if the meshes they wear are sensitive to this issue (*). Also, if you activate the "Force Mesh Deformer" advanced setting (something that should not be done but for debugging and testing), then the work around I implemented will be bypassed and you will see the "jumping" happening for all avatars wearing affected rigged mesh attachments (*).

I posted a report on Qarl's blog to make him aware of this issue, but the true fix for this glitch is to have SH-3013 fixed (please, vote for it).


(*) affected rigged meshes are the ones with a non-zero offset.


2012-03-24 10:02:11
Profile WWW

Joined: 2012-02-09 21:01:50
Posts: 284
Reply with quote
Wootwoot! :D

And voted for the bug.


2012-03-25 09:43:19
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 2 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.