Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2019-08-23 09:09:54



Reply to topic  [ 6 posts ] 
Difficulty working with flexible prims 
Author Message

Joined: 2012-06-24 15:07:40
Posts: 22
Reply with quote
Hello! I'm a creator and use flexible prims quite frequently. While working, I have experienced the following glitches:
1. When creating a flexible prim, it does not become flexible while in edit. After the edit window is closed, it becomes flexible.
2. When wearing a flexible objects (i.e., a skirt), and editing linked parts, the flexi-prims appear to stay in their original position, while an outline of them moves with the edit arrows. Once the edit window is closed, the new position of the prims is visible. This makes it very difficult to achieve accurate edits.

This has been occurring with all versions of the Cool VL Viewer since I started using it about 4 months ago. Here's my system info:
Cool VL Viewer 1.26.4 (15) May 25 2012 21:34:27 (Cool VL Viewer)
Release Notes

Built with MSVC version 1400


Second\ Life\ Server 12.06.06.259024
Release Notes: Error fetching server release notes URL.

CPU: Intel(R) Core(TM) i7-2820QM CPU @ 2.30GHz (2294.81 MHz)
Memory: 16362 MB
OS Version: Microsoft Windows 7 64-bit Service Pack 1 (Build 7601)
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce GTX 580M/PCIe/SSE2
Windows Graphics Driver Version: 8.17.0013.0142
OpenGL Version: 4.2.0

libcurl Version: libcurl/7.21.1 OpenSSL/0.9.8j zlib/1.2.3 c-ares/1.7.1
J2C Decoder Version: KDU
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.7.1 (version number hard-coded)
Packets Lost: 0/6559 (0.0%)

I took screenshots to demonstrate/illustrate the issue, but it seems they are too large to post here (my apologies).


2012-06-24 15:30:19
Profile

Joined: 2011-12-13 14:11:38
Posts: 147
Reply with quote
Hello Arwen,

I've already reported this bug here: http://sldev.free.fr/forum/viewtopic.php?f=6&t=703. You can read Henri's answers in this thread.
- Erika -


2012-06-24 16:50:42
Profile

Joined: 2012-06-24 15:07:40
Posts: 22
Reply with quote
Thank you Erica for pointing me to that thread (when I searched, I just looked in bug reports).
Yes, that's exactly what I experience, too. I guess I will use another viewer when I do my flexi-editing and creating, and use Cool VL Viewer for everything else (I love it except for this one issue).


2012-06-24 16:57:02
Profile

Joined: 2009-03-17 18:42:51
Posts: 4021
Reply with quote
Yes, I knew about this quirk and looking again at the code today, I found the problem (a missing line in llmanip.cpp when I ported the mesh renderer to the Cool VL Viewer).

It will be fixed in v1.26.4.20.


2012-06-24 17:59:53
Profile WWW

Joined: 2012-06-24 15:07:40
Posts: 22
Reply with quote
Thank you Henri! I'm so glad you were able to identify the issue and will be able to correct it. I am totally in love with the Cool VL Viewer and so thankful that you have created it :!:


2012-06-24 18:32:13
Profile

Joined: 2012-06-24 15:07:40
Posts: 22
Reply with quote
I just installed and tried the new Cool VL Viewer (release 6/30 version). It's awesome! This bug is totally fixed, and whatever other tweaking you did, Henri, has skyrocketed my fps! What a pleasure to use your viewer! Thank you! :D


2012-07-02 18:51:32
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.