Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-09-25 22:30:37



Reply to topic  [ 4 posts ] 
Can't play media - can't run new Cool VL installer 
Author Message

Joined: 2016-05-26 00:41:06
Posts: 2
Reply with quote
Hi Henri,

I know you must be very busy and it never fails to astonish me how you keep the Cool VL Viewer updated, so thanks very much for years of great service.

Sorry to lump 2 (3?) problems together, but they may be related.,

First of all, I've always appreciated your viewer, I've been using it forever, (9 years?)

Sadly my SL experience is growing tarnished by all the technicalities these days, so I am spending more time trying to solve issues than I am enjoying SL.

3Dconnexion stopped developing for SL, so I am having to use an out-dated driver for their 3D joystick which actually works with your viewer and Firestorm, but not with SLV2. However it screams out a list of errors every boot up.

Anyway...
I can view in-world media like movies in SLV2 & Firestorm, but not your viewer any more.

I've hunted high and low in your forums, but can't seem to find the definitive answer. I get this problem every so often and I usually find the fix. Not this time.
I have installed gstreamer.msi, but no joy.
I had Quicktime installed, but that didn't work, so I installed the Quicktime alternative (which I think I found somewhere in your forums).
Currently the media screen goes black, but nothing happens. If I click on the screen I get a little menu bar with some controls, including open in browser, but that is just black too.

I tried to upgrade to the latest version of your viewer, but I get this;
"can't find a usable init.tc. in the following directories. ...
This probably means that Tcl wasn't installed properly"

I haven't a clue what it is looking for and can't find it in my local PC search nor can I find anything helpful at all online.

I am hoping that a new install might solve all three problems, but I can't work this out by myself. I am not very technical with programming code, but I can usually manage to update drivers, etc. if I have clear step by step instructions.

Sorry for being a nuisance. The only option I have at the moment is to use Firestorm and I don't like it, so I only use it when I want to watch media. I've always hated SLV2.

Thanks for all your great work!!! I can't tell you how much I appreciate Cool VL Viewer.

regards, MrEbo


2017-05-23 19:46:28
Profile

Joined: 2009-03-17 18:42:51
Posts: 3630
Reply with quote
Are you trying to install the 64 bits viewer on a 32 bits system ?

This is what the tcl error would hint for...

In any case, without details about your system and without logs, I cannot do any investigation...


2017-05-23 21:28:19
Profile WWW

Joined: 2016-05-26 00:41:06
Posts: 2
Reply with quote
Hi Henri,

Sorry, been too busy to be in SL for a while.

I am running Windows 8.1 ... 64 bit.

I was running okay on Cool Viewer v1.26.20 but updating since then has failed due to this missing TCL thing.

I checked out some BB's on what to do and one wanted me to do stuff in C, which is probably beyond me.
Another suggested downloading ACTIVETCL which at least was an .exe file, however, that didn't work for me.

I noted the directory names that the Cool VR installer threw up with the error report and tried to reinstall in one of those, but it mentions ver 8.5 and the version I got from Active State website is 8.6 so maybe that is why it can't find it now.

I noticed on the 2nd install that there seems to be some issue where I can't uninstall TCL from the control panel, so it apparently puts something in the start menu. No idea where that is as I don't see anything obvious there.
The installer mentions stuff about the registry and I haven't a clue what it means.

It's all getting FAR too technical for me.

I've just searched manually for tcl.init and it is in c:\users\Ian\lib\lib, as it has added the 2nd lib, so I tried reinstalling it in c:\users\Ian and can't find it now, so I copied the files there from the lib\lib sub dir and that didn't work. (I didn't think it would)

I better see if I can uninstall it all now. I don't suppose just deleting all the files will do any good.

oh dear, a little knowledge is a dangerous thing.


I think I better give up before I really make a mess.

Thanks anyway. Sorry for being a nuisance.


2017-07-10 21:15:59
Profile

Joined: 2009-03-17 18:42:51
Posts: 3630
Reply with quote
You do not need to install Tcl/Tk: the installer got its own TclKit bundled.


2017-07-10 22:50:16
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.