Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2022-10-06 01:26:47



Reply to topic  [ 8 posts ] 
Question for Linux users: what is your glibc version ? 

What are your Linux distro glibc & libstdc++ versions ?
Poll ended at 2022-04-22 08:25:44
glibc v2.27 or newer, libstdc++ v6.0.25 or newer 89%  89%  [ 8 ]
Anything older 11%  11%  [ 1 ]
Total votes : 9

Question for Linux users: what is your glibc version ? 
Author Message

Joined: 2009-03-17 18:42:51
Posts: 5022
Reply with quote
With the new "performance viewer" introduced by LL, gcc v5.5 became incapable to compile some parts of its code... This forces me to move away from my old 2016-ish build system for official Linux builds and adopt a newer build system with a more capable compiler.
Since I am already using Ubuntu 18.04 LTS to build Dullahan (the CEF plugin) and this system got gcc v7.5 (which compiles the new code just fine), I will adopt it for building the next releases of the v1.29.0 experimental branch (and v1.30.0 when the experimental branch will go stable, see the roadmap).

Now, it would be really nice if I could use the same 2018-ish build system to also build the current stable (and future legacy) branch (v1.28.2); this of course depends whether some of you are "stuck" with an old Linux distribution or not... So, here is the question for this poll: what are your Linux distro glibc & libstdc++ versions ?

Of course, only Linux users should reply to this poll (and thanks in advance to them for indeed replying it).


2022-04-07 08:25:44
Profile WWW

Joined: 2012-08-08 17:51:35
Posts: 72
Reply with quote
As a Debian user (on the stable channel) I might be able to share some more or less useful data, as the distro never uses the latest shiny ;)

My current Debian Stable (Bullseye/11) have glibc 2.31 and libstdc++ 9 and 10.
The oldstable release (Buster/10) has glibc 2.28 and libstdc++ 7 and 8 if I'm not mistaken (can't check now, what I have around me is on stable).

If you want some long term backwards compatibility, here's some more data that might share some light about other environments.
(Partial source https://wiki.debian.org/DebianReleases).
  • Debian 11, current stable, is supposedly supported to 2026 (including LTS status after 2024-ish).
  • Debian 10 enters LTS status this summer, possibly august, and will be maintained to 2024-ish.
  • Debian 9, which does not reach your suggested level (glibc 2.24, libstdc++ 6) leaves LTS two months approximately. Unless it hits extended LTS it's EOL at that date.

I hope it helps some (as I know that many other distros have their roots in this one) ^^


2022-04-09 16:10:44
Profile

Joined: 2009-03-17 18:42:51
Posts: 5022
Reply with quote
It is not so much about what are the current distros based off, than about what dilemma some users might have to face whenever a particular piece of software required by their (sometimes not that old) computer, e.g. some driver, becomes unmaintained and forces them to stay stuck with an old distro to keep their PC running.

I have been the victim of such an issue, back in 2009, when AMD decided to stop providing drivers for their (only 4 years old !) ATI Radeon Mobility GPUs, and my 4 years old notebook suddenly got stuck with old kernel and X11 versions (because the old driver won't compile against newer ones). Since this day, I stopped buying ATI/AMD GPUs (in contrast, NVIDIA provides updated drivers for at least 10 years after a particular GPU model got released: I still can run a 11+ years old GTX 460 today with updated drivers compiling fine against the latest Linux kernel and X11 release), but this kind of bad surprise is hard to predict in advance...

This is why I always did my best to support "old" Linux distros by compiling the viewer on them, rather than on newer ones (like almost all other TPVs are doing, by the way)...


2022-04-09 17:04:54
Profile WWW

Joined: 2022-04-13 22:13:27
Posts: 4
Reply with quote
I did add "older version" in poll - some details: I use Opensuse Leap 15.1 as my main system, self maintained (I am a bit conservative as dislike some new features in newer version of distros). Libstdc isn't the problem, but sadly glibc stuck at 2.26. I don't feel "experienced" enough though to do on my own patch glibc to higher level, and Leap 15.3 upwards is not a choice at the moment.


2022-04-13 22:34:27
Profile

Joined: 2009-03-17 18:42:51
Posts: 5022
Reply with quote
GismoZ wrote:
I use Opensuse Leap 15.1 as my main system, self maintained (I am a bit conservative as dislike some new features in newer version of distros). .../... and Leap 15.3 upwards is not a choice at the moment.
I totally understand your point of view; to give you an example, I am still using a self-maintained MATE v1.14 desktop on my PCLinuxOS machines (while this is a rolling release distro), because I cannot stand GTK3...
However, when you opt for such a resistance to (bad) changes, you must endorse the consequences (here, patching and rebuilding the software as needed when new library versions arise with incompatibilities)...

Quote:
Libstdc isn't the problem
I would have preferred it to be the problem... It is easy to provide an optional libstdc++ "package" (i.e. just a tarball with an appropriate libstdc++ library) to supplement the viewer installation for people with too old a library on their system... glibc is another story !

Quote:
but sadly glibc stuck at 2.26. I don't feel "experienced" enough though to do on my own patch glibc to higher level
Well, you could probably find glibc v2.27 packages and try and install them "manually" (i.e. with "rpm" invoked from a terminal) on your old system... This should not break anything (glibc is, usually, upward compatible, and IIRC v2.27 was not one of the rare problematic updates requiring recompilation of other software).

You could also try to run v1.29.0.2 as released today: if it runs fine on your system, it means it does not use any of the new glibc functions introduced in v2.27, and v1.28.2 would run just as fine when compiled against v2.27...

Finally, please note that:
  • v1.29.0 official releases (and the future v1.30.0 stable branch) will never be built any more against an older glibc than v2.27 so, eventually, and if it cannot run against v2.26, you will be left with just the legacy branch (which will go unmaintained, likely in a few months).
  • It will still be possible to build v1.28.2 yourself against your glibc version for as long as I will keep providing it, even if I end up providing official builds done against glibc v2.27.

Please, let me know if any of the above would "solve" your issue.


2022-04-16 13:19:22
Profile WWW

Joined: 2022-04-13 22:13:27
Posts: 4
Reply with quote
Upfront - Thank you very much for all that information! It been very useful. I haven't had much time today, so just some feedback, and more better formatted next days.

At first 1.29.0.2 here cannot be started, as it claims missing lib /also in check-libs: "Launching the viewer...
./bin/cool_vl_viewer-bin: /lib64/libm.so.6: version `GLIBC_2.27' not found (required by ./bin/cool_vl_viewer-bin)
*** Bad shutdown. ***
"

So I checked if I find repository, and yes one Intel related project person did one build in 2021. I am just a bit cautious not to break system even all dependencies looked well. I will consider that after a kind of test on a copy which means time to spend...

So i searched for another option, safe to my system, and found one, compiling GLIBC from source, install it in a different folder, and tell system to use for the one library that folder by "LD_PRELOAD=/opt/glibc-2.27/lib/libm.so.6 ./cool_vl_viewer". It been late i made some silly syntax errors, not sure if preload lib64 folder instead, and so on not got it loaded. Maybe I fiddle that out tomorrow...

But finally just tired of it decided to copy the "libm-2.27.so" into the lib folder of Cool VL Viewer, made symbolic link to it named "libm.so.6" - and it worked! So a workaround for the moment, and see how long it works until segmentation faults ...

So just bit feedback for now


2022-04-17 22:50:45
Profile

Joined: 2009-03-17 18:42:51
Posts: 5022
Reply with quote
GismoZ wrote:
So I checked if I find repository, and yes one Intel related project person did one build in 2021.
I made a simple web search for "Opensuse glibc 2.27 rpm" and this came up as the first result glibc v2.27 for openSUSE Leap 15... There is a link to the source rpm as well, so it should be easy to rebuild it on Leap 15.1.


2022-04-17 23:19:03
Profile WWW

Joined: 2022-04-13 22:13:27
Posts: 4
Reply with quote
Thank you - Yes and i found that one, https://build.opensuse.org/package/revisions/home:cabelo:intel/glibc, looks pretty well, just not sure how all the other applications will act on, so I need testing or thinking how to reverse if ...

I will probably upgrade next to Opensuse 15.4 when released, as I dislike 15.3. Btw, they kept to 2.26 5 years old until 15.3, as they make software same versions as their enterprise edition, so yes stable, but outdated some times... 2.27 is 2017 ...

The above "Hack" / workaround i mentioned seems NOW in this version stable, i testing 1.29.0.2 now and its beautiful performance improvement :)


2022-04-17 23:32:38
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 8 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.