Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2024-05-19 22:11:05



Reply to topic  [ 11 posts ]  Go to page 1, 2  Next
Media issue again 
Author Message

Joined: 2011-09-27 11:18:31
Posts: 180
Reply with quote
Hello.

I went to the Cool VL Viewer house at Hippo Hollow and tried to use the media board on the wall. I made a video to show exactly what happens, it's here: https://drive.google.com/file/d/16mG9XK ... sp=sharing . In short, the media will open when I zoom in it (not otherwise) and only until I try to click to a link, then it dies. That happens for quite sometime now with the HiVid TV that I mentioned at another thread, but only today did I realise it happens with websites as well.

Any help appreciated.

I'm attaching the log. About > Info:
Quote:
Cool VL Viewer v1.32.0.16, Mar 30 2024 14:14:49
RestrainedLove viewer v2.09.29.29
Release notes

You are at 238100.7, 244881.9, 49.1 in Hippo Hollow located at
simhost-0f06fec2cb6153746.agni.secondlife.io (35.87.152.251:13028)
Alias: 251.152.87.35.in-addr.arpa
Second Life Server 2024-02-21.7995320426
Release notes: Retrieving...

CPU: AMD Ryzen 5 4500 6-Core Processor (4184 MHz)
Memory: 31882MB
OS version: Linux-x86_64 v6.6.21-gentoo-dist
Memory manager: jemalloc v5.3.1-20240316
Graphics: AMD RADEON RX 580 SERIES (RADEONSI, POLARIS10, LLVM 17.0.6, DRM 3.54, 6.6.21-GENTOO-DIST)
OpenGL version: 4.6 (Core Profile) Mesa 23.3.6
Detected VRAM: 10064MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.03.00 (PulseAudio)
Networking backend: libcurl 7.47.0/OpenSSL 1.0.2u/zlib 1.3.0.zlib-ng
Browser plugin: Dullahan 1.13.2/CEF 122.1.13/Chromium 122.0.6261.130
Packets lost: 204/43926 (0.5%)

Built with: GCC v13.2.1
Compiler-generated maths: SSE2.

Compile flags used for this build:
-O3 -fno-delete-null-pointer-checks -fno-ipa-cp-clone -fno-align-labels -fno-align-loops -fsched-pressure -frename-registers -fweb -fira-hoist-pressure -DNDEBUG -std=c++17 -fno-stack-protector -U_FORTIFY_SOURCE -fno-threadsafe-statics -fPIC -pipe -g -gdwarf-4 -fno-var-tracking-assignments -fexceptions -fno-strict-aliasing -fvisibility=hidden -fsigned-char -m64 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread -DLL_LINUX=1 -DLL_JEMALLOC=1 -DLL_FMOD=1 -DLL_OPENAL=1


Attachments:
CoolVLViewer 20240330.tar.gz [35.94 KiB]
Downloaded 19 times
2024-03-30 17:13:22
Profile

Joined: 2009-03-17 18:42:51
Posts: 5587
Reply with quote
This is apparently a CEF crash.

But you are using a custom build of the viewer. I can only offer support for official builds.

Please, try with the official build and see how it fares.


2024-03-30 20:57:20
Profile WWW

Joined: 2011-09-27 11:18:31
Posts: 180
Reply with quote
Same thing, I'm afraid. Which is reasonable, since the only patch I use while self-compiling is this, but one never knows. I'm adding the new log.

Code:
Cool VL Viewer v1.32.0.16, Mar 30 2024 09:31:10
RestrainedLove viewer v2.09.29.28
Release notes

You are at 238107.8, 244879.3, 49.1  in Hippo Hollow located at
simhost-0f06fec2cb6153746.agni.secondlife.io (35.87.152.251:13028)
Alias: 251.152.87.35.in-addr.arpa
Second Life Server 2024-02-21.7995320426
Release notes

CPU: AMD Ryzen 5 4500 6-Core Processor (4191 MHz)
Memory: 31882MB
OS version: Linux-x86_64 v6.6.21-gentoo-dist
Memory manager: jemalloc v5.3.1-20240316
Graphics: AMD RADEON RX 580 SERIES (RADEONSI, POLARIS10, LLVM 17.0.6, DRM 3.54, 6.6.21-GENTOO-DIST)
OpenGL version: 4.6 (Core Profile) Mesa 23.3.6
Detected VRAM: 9853MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.03.00 (PulseAudio)
Networking backend: libcurl 7.47.0/OpenSSL 1.0.2u/zlib 1.3.0.zlib-ng
Browser plugin: Dullahan 1.13.2/CEF 122.1.13/Chromium 122.0.6261.130
Packets lost: 358/20225 (1.8%)

Built with: GCC v8.3.0
Compiler-generated maths: SSE2.

Compile flags used for this build:
-O3 -fno-delete-null-pointer-checks -fno-ipa-cp-clone -fno-align-labels -fno-align-loops -fsched-pressure -frename-registers -fweb -fira-hoist-pressure -DNDEBUG -std=c++17 -fno-stack-protector -U_FORTIFY_SOURCE -fno-threadsafe-statics -fPIC -pipe -g -gdwarf-4 -fno-var-tracking-assignments -fexceptions -fno-strict-aliasing -fvisibility=hidden -fsigned-char -m64 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread  -DLL_LINUX=1 -DLL_JEMALLOC=1 -DLL_FMOD=1 -DLL_OPENAL=1


Attachments:
CoolVLViewer-20240331.tar.gz [31 KiB]
Downloaded 20 times
2024-03-31 12:33:22
Profile

Joined: 2009-03-17 18:42:51
Posts: 5587
Reply with quote
Thing is, everything is working just fine here, on 5 different computers (including a Linux aarch64 SBC)...

If CEF crashes on your Linux PC, then it might be something it does not like on it, but I'm afraid I cannot help you on this front (I develop the viewer, not CEF)...


2024-03-31 12:55:46
Profile WWW

Joined: 2011-09-27 11:18:31
Posts: 180
Reply with quote
*Sighs* I understand.


2024-03-31 13:17:24
Profile

Joined: 2009-03-17 18:42:51
Posts: 5587
Reply with quote
If anything, you could try a build without jemalloc (USE_JEMALLOC option in indra/cmake/00-BuildOptions.cmake), since a usual suspect for CEF crashes is its shitty memory allocator: maybe it does not like your glibc version (since you are using gcc 13, I assume it is a very recent version too)...


2024-03-31 16:33:24
Profile WWW

Joined: 2011-09-27 11:18:31
Posts: 180
Reply with quote
I just wanted to report that, when I toggle Preferences > Audio and Media > Media > Play shared media (aka "media on a prim"), media on a prim seem to work as expected. Go figure.


2024-04-21 17:45:04
Profile

Joined: 2009-03-17 18:42:51
Posts: 5587
Reply with quote
g0rd0ngrfr33mailgr wrote:
I just wanted to report that, when I toggle Preferences > Audio and Media > Media > Play shared media (aka "media on a prim"), media on a prim seem to work as expected. Go figure.
:shock:

Err... I do confirm that to see media on a prim, you need media on a prim enabled... :lol:


2024-04-21 18:48:51
Profile WWW

Joined: 2011-09-27 11:18:31
Posts: 180
Reply with quote
Henri Beauchamp wrote:
g0rd0ngrfr33mailgr wrote:
I just wanted to report that, when I toggle Preferences > Audio and Media > Media > Play shared media (aka "media on a prim"), media on a prim seem to work as expected. Go figure.
:shock:

Err... I do confirm that to see media on a prim, you need media on a prim enabled... :lol:

:roll: I do, lol. I mean I have to disable and re-enable. :lol:


2024-04-21 19:28:21
Profile

Joined: 2009-03-17 18:42:51
Posts: 5587
Reply with quote
g0rd0ngrfr33mailgr wrote:
:roll: I do, lol. I mean I have to disable and re-enable. :lol:
:P

In any case, I cannot either reproduce this here (I can either login with MOAP enabled, or enable it later, and the CEF media still play fine)...

Strange, to say the least, especially since it won't make any difference for the CEF plugin itself (which just loads the URL it is passed, be it started or restarted won't matter the least: it is still the same URL).


2024-04-21 21:39:32
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 11 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.