Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-06-28 05:15:24



Reply to topic  [ 6 posts ] 
Can only restart one sim and have to relog for next 
Author Message

Joined: 2015-01-27 07:04:47
Posts: 3
Reply with quote
In the new version 1.26.20 Linux 64 bit, i can only restart one sim.
If i try to restart the next sim i can press the restart button, but the sim does not do the restart.
After relog i can restart the next sim ..

As i do a restart of 5 sims in a row every morning, it is a bit annoying :-)


2016-12-13 21:39:10
Profile

Joined: 2009-03-17 18:42:51
Posts: 3583
Reply with quote
I don't understand a word of what you are saying... Please, follow the rules, and provide logs and full repro steps.


2016-12-13 23:45:39
Profile WWW

Joined: 2015-01-27 07:04:47
Posts: 3
Reply with quote
Sorry, thought it would be obvious.

Because reproduction in SL is not that easy (not everyone is estate admin on more than one sim), and i am not happy with posting those logs, i repoduced the same issue in Zetaworlds (connected to Hypergrid).
If you need estate rights there for reproduction of the issue i can give you ..

Reproduction :
1 - log in.
2 - call up World -> Region/Estate floater (a shortcut like singularity's ALT-R would be handy :-) )
3 - go to debug tab
4 - press restart region
5 - press ok
6 - press ok for notice that region will be restarted..
7 - go to next sim
8 - press restart region
9 - press ok
now nothing happens .. relog is needed for next restart region

processor and system info is in log but here from Help :
Cool VL Viewer v1.26.20.0, 64 bits, Dec 10 2016 09:25:22
Release Notes

You are at 1793342.6, 1793459.1, 24.9 in Wild Saba located at static.inet.networkconcepts.nl (185.3.177.49:9000)
ZW-OpenSim 0.9.0.0 Dragon (Unix/Mono)

CPU: AMD FX(tm)-6300 Six-Core Processor (2000 MHz)
Memory: 16076 MB
OS version: Linux-x86_64 v4.8.0-31-generic #33-Ubuntu SMP Wed Dec 7 15:14:02 UTC 2016
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTX 660 Ti/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 375.20

J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: FMOD Ex v4.44.64 (PulseAudio)
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1i zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3c-(CEF-LIN-3.2526.1371-64)
Packets lost: 0/1892 (0.0%)

Built with GCC version 4.6.4

Compile flags used for this build:
-O3 -fno-delete-null-pointer-checks -fno-align-labels -fno-align-loops -fno-ipa-cp-clone -fsched-pressure -frename-registers -fweb -DNDEBUG -pipe -g -fexceptions -fno-strict-aliasing -fvisibility=hidden -fsigned-char -m64 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread -fno-stack-protector -Wall -Wno-reorder -Werror -DLL_LINUX=1 -D_REENTRANT -DXML_STATIC -DLL_ELFBIN=1 -DOV_EXCLUDE_STATIC_CALLBACKS -DLL_FMODEX=1 -DLL_OPENAL=1 -DLL_SDL=1 -DLIB_NDOF=1 -DLL_X11=1


Attachments:
CoolVLViewer.zip [19.84 KiB]
Downloaded 11 times
2016-12-15 09:48:01
Profile

Joined: 2009-03-17 18:42:51
Posts: 3583
Reply with quote
Thank you. Sadly, there is nothing wrong in the log, and I cannot test this process myself (I only own a main land parcel, and can't therefore restart a region, even less several in a raw...).

However, nothing changed in this part of the code in many many months, so my next question is: which version of the Cool VL Viewer last worked as expected in this respect for you ?

Also, your procedure seems quite a bit flaky: normally, the region floater gets attached to the current region your avatar stands in. If you restart the said region, the floater becomes stale (deprecated/inactive), which is normal. You should therefore close it and re-open it once TPed in the next region. What happens if you proceed this way:
  1. log in.
  2. call up World -> Region/Estate floater
  3. go to debug tab
  4. press restart region
  5. press ok
  6. press ok for notice that region will be restarted..
  7. close Region/Estate floater
  8. go to next sim
  9. call up World -> Region/Estate floater
  10. go to debug tab
  11. press restart region
  12. press ok


2016-12-15 10:16:51
Profile WWW

Joined: 2015-01-27 07:04:47
Posts: 3
Reply with quote
yes, you are right .. closing and reopening the floater solves the problem.
i never thought about reopening the floater because i was using singularity recently and there the floaters update at sim crossings.


2016-12-15 10:27:55
Profile

Joined: 2009-03-17 18:42:51
Posts: 3583
Reply with quote
Si Shinn wrote:
yes, you are right .. closing and reopening the floater solves the problem.
i never thought about reopening the floater because i was using singularity recently and there the floaters update at sim crossings.

Never assume all viewers are working the same way (they don't !): in the Cool VL Viewer the region floater is kept attached to the region you opened it in (this way, you should even be able to restart a region after TP into another region).


2016-12-15 10:32:45
Profile WWW
Display posts from previous:  Sort by  
Reply to topic   [ 6 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.