Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-09-26 05:43:31



Reply to topic  [ 4 posts ] 
LL standard animation "clap" broken in v1.26.20.10 on Mac. 
Author Message

Joined: 2012-01-19 03:18:40
Posts: 100
Reply with quote
Somewhere between v1.26.20.7 (under which it worked) and v1.26.20.10 (under which it fails) something seems to have broken the standard LL animation "clap", at least on Mac. I am running this:

Code:
Cool VL Viewer v1.26.20.10, 32 bits, Feb 27 2017 19:16:39
RestrainedLove viewer v2.09.21.21
Release Notes

CPU: Intel(R) Core(TM) i7-4771 CPU @ 3.50GHz (3500 MHz)
Memory: 16384MB
OS version: Mac OS X 10.11.6 Darwin 15.6.0 Darwin Kernel Version 15.6.0: Mon Jan  9 23:07:29 PST 2017; root:xnu-3248.60.11.2.1~1/RELEASE_X86_64 x86_64
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: NVIDIA GeForce GTX 780M OpenGL Engine
OpenGL version: 2.1 NVIDIA-10.10.14 310.42.25f02
Detected VRAM: 4096MB
J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: FMOD Ex v4.44.64
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1h zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3-(CEF-OSX-3.2171.2069-32)

Built with: Clang/LLVM v7.3.0

Compile flags used for this build:
-O3 -DNDEBUG -pipe -g -fexceptions -fno-strict-aliasing -fvisibility-inlines-hidden -fsigned-char -m32 -march=pentium4 -msse2 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread -fno-stack-protector -Wall -Wno-reorder -Wno-unused-local-typedef -Wno-unused-const-variable -Wno-unused-function -Wno-unused-value -Wno-gnu -Werror -DLL_DARWIN=1 -DXML_STATIC -DLL_PRIVATE_MEMORY_POOLS=1 -DLL_VB_MEM_POOL=1 -DLL_VOLUME_MEM_POOL=1 -DLL_LUA=1 -DOV_EXCLUDE_STATIC_CALLBACKS -DLL_FMODEX=1 -DLIB_NDOF=1

I have attached my log file, but the error seems to be:

Code:
2017-03-15T22:14:34Z WARNING: LLKeyframeMotion::deserialize: Bad number of constraints: 11
2017-03-15T22:14:34Z WARNING: LLKeyframeMotion::onInitialize: Failed to decode asset for animation clap:9b0c1c4e-8ac7-7969-1494-28c874c4f668
2017-03-15T22:14:34Z INFO: LLMotionController::createMotion: Motion 9b0c1c4e-8ac7-7969-1494-28c874c4f668 init failed.
2017-03-15T22:14:34Z WARNING: LLVOAvatar::processSingleAnimationStateChange: Failed to start motion!

This animation does work in the current LL viewer 5.0.3.


Attachments:
CoolVLViewer.log.zip [14.61 KiB]
Downloaded 7 times
2017-03-15 22:33:37
Profile

Joined: 2009-03-17 18:42:51
Posts: 3630
Reply with quote
Not a bug, but the expected behaviour: the animation is faulty as it includes too large a number of constraints.

Other viewers (and old Cool VL Viewer releases) ignore all the constraints altogether when such an anim is encountered, but I found out it could cause crashes (especially when it's an anim designed to be played on rigged meshes), so I changed the code to refuse playing such bogus anims instead... This was documented in the corresponding release notes.


2017-03-15 23:01:50
Profile WWW

Joined: 2012-01-19 03:18:40
Posts: 100
Reply with quote
Ah, I see. Fair enough, I guess I have to go looking for a new animation. I think I have the .bvh file for the anim, so I might try uploading it myself to see if that fixes anything.


2017-03-16 01:00:38
Profile

Joined: 2012-01-19 03:18:40
Posts: 100
Reply with quote
Fixed it! I loaded the .bvh file for the animation into QAvimator, and then exported it to another file name. Then I uploaded the animation to SL in the usual way, and it worked fine. QAvimator can apparently digest the bad .bvh file, and export it in a cleaned up format that works with Cool VL Viewer.


2017-03-16 02:04:51
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 4 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.