Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2017-05-23 05:03:51



Reply to topic  [ 3 posts ] 
Hide particles shortcut keys 
Author Message

Joined: 2016-06-19 21:33:37
Posts: 62
Reply with quote
The shortcut key combination for Hide particles doesn't work for me. The actual Hide particles menu option performs the function properly when using the mouse. I haven't found any other mention in the forums or via Google so it may be my set up, Fedora distro, Gnome, etc. Wondered if anyone else can confirm.

My info:
Code:
Cool VL Viewer v1.26.20.7, 64 bits, Feb 11 2017 09:01:39
Release Notes

You are at 196727.7, 308919.2, 24.5  in Innsmouth located at
sim10450.agni.lindenlab.com (216.82.51.156:13004)
Second Life Server 17.01.27.323172
Release Notes

CPU: AMD A4-7300 APU with Radeon HD Graphics (2200 MHz)
Memory: 16073MB
OS version: Linux-x86_64 v4.9.8-201.fc25.x86_64 #1 SMP Tue Feb 7 11:28:07 UTC 2017
Memory manager: OS native
Graphics card vendor: NVIDIA Corporation
Graphics card: GeForce GTS 450/PCIe/SSE2
OpenGL version: 4.5.0 NVIDIA 375.26
Detected VRAM: 1024MB
J2C decoder: OpenJPEG: 1.4.0.635d
Audio driver: OpenAL v1.1 ALSOFT 1.17.2 (OpenAL Soft: OpenAL Soft)
Networking backend: libcurl/7.47.0 OpenSSL/1.0.1i zlib/1.2.8
Embedded browser: CEF3 plugin v1.5.3c-(CEF-LIN-3.2526.1371-64)
Packets lost: 0/44947 (0.0%)

Built with: GCC v4.6.4

Compile flags used for this build:
-O3 -fno-delete-null-pointer-checks -fno-align-labels -fno-align-loops -fno-ipa-cp-clone -fsched-pressure -frename-registers -fweb -DNDEBUG -pipe -g -fexceptions -fno-strict-aliasing -fvisibility=hidden -fsigned-char -m64 -mfpmath=sse -fno-math-errno -fno-trapping-math -pthread -fno-stack-protector -Wall -Wno-reorder -Werror -DLL_LINUX=1 -D_REENTRANT -DXML_STATIC -DLL_ELFBIN=1 -DLL_LUA=1 -DOV_EXCLUDE_STATIC_CALLBACKS -DLL_FMODEX=1 -DLL_OPENAL=1 -DLL_SDL=1 -DLIB_NDOF=1 -DLL_X11=1


2017-02-12 05:22:59
Profile

Joined: 2009-03-17 18:42:51
Posts: 3558
Reply with quote
Sadly, many shortcut keys (all the ones using the upper row of the keyboard keys, i.e. "1" to "=") are unsuitable for anything else than QWERTY keyboards with English system locale. This is in no way a bug, but just a known limitation. Be also wary of your Gnome keyboard shortcuts that may conflict with other applications (SL viewers included).

I might add a Lua function to toggle render debug features, which would allow to setup a side bar button for them, for quick access...


2017-02-12 09:36:36
Profile WWW

Joined: 2016-06-19 21:33:37
Posts: 62
Reply with quote
Fortunately I do meet the QWERTY and English locale conditions. Indeed, all of the other render debug options work just fine (1-0 and \). I have verified that the default keyboard shortcuts (that I can see/configure), do not have the 4 key combo in question. I wondered/speculated if the problem could have anything to do with the setting being available in more than one menu. It seems to be the only render option like that.

This isn't a big pain point though. I can click a menu item via mouse fairly easily. I just happened to stumble upon it when I was in a heavily particled area when I wanted to quickly toggle them and thought I would mention it here.

Cheers.


2017-02-12 14:01:21
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.