Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2020-03-31 14:11:04



Reply to topic  [ 5 posts ] 
install probs both branches for Windoze 
Author Message

Joined: 2016-05-26 00:41:06
Posts: 5
Reply with quote
Hi Henri,

[LOVE Cool Viewer, - can it really be 10 years or more I've been using it?]

I Was getting some issues with Maitreya layers & wall textures.
Maitreya layers keep vanishing - seems to be when I TP or log in.
wall texture went to random digital nonsense. (that was a one-off)

So, I thought I would update my Cool VL Viewer yesterday.
Downloaded 1.2.6.22.54.
Got an err, relating to a DLL missing.
The installer then froze and I had to use task manager to stop the process.



Messed around a bit ran sfc - it couldn't fix it.

Went back today, hoping to find a new ver. yep - got 1.2.6.22.55

For the first time ever my Avast Anti-virus triggered saying "rare file - we'll analyse it" but later came back "its clean"

but then it also borked. Says "Windows cannot access the specified device - or you may not have permissions to access the item.
(I don't think I got asked where I wanted to install, but I may not have been paying attention)

I tried the experimental branch today - just in case, but same probs as .54

once again the installer froze and wouldn't cancel or close.

A second problem is I am not seeing your website properly any more.
Trying to go to the page to download win ver it comes up with your header graphic multiple times in a pile.

I've tried Chrome and Firefox.

Having to limp by with Firestorm till I can get my favourite viewer back, but thanks for your dedication, it is much appreciated.
(It is when I have to use a different viewer I realise how addicted to Cool I am. )


Attachments:
File comment: tried uploading png of the errs & site not displaying properly, but can't
Cool err log.log [3.05 KiB]
Downloaded 71 times


Last edited by MrEbo on 2019-08-04 09:49:24, edited 1 time in total.

2019-08-04 09:47:31
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
You are probably the victim of a malware.

The failed DLL ("C:/Users/Ian/lib/thread2.7.2/thread272.dll") is not even part of the installer. Its path points to your user directory, which is totally abnormal, like is abnormal the fact something on your system tries to load it when you launch the installer.

In any case, there is no issue with the installer (neither any change to it in years) on Windows systems. I tested it myself on 7 different systems: 3 VMs (2 * Windows 7 Ultimate, Windows 10 1809), and 4 "bare metal" systems (on two different PCs): 2 * Windows 7 Ultimate, Windows 10 1809 and Windows 10 1903. No one else seems to encounter any issue either.

Your problem with the web site is also a mystery (working just fine here and for everyone else) that only a malware (or a really f*cked up anti-virus) could explain.


2019-08-04 10:00:23
Profile WWW

Joined: 2016-05-26 00:41:06
Posts: 5
Reply with quote
Hi Henri,

Thanks very much for that. It is working now.


I've run a scan (hitman pro) which said "no threats", but did flag up some spyware, so I cleaned that.

Also uninstalled the old Cool Viewer
(which hadn't been running since I started trying to reinstall over the past couple of days - as it was apparently wanting fmod67.dll)

Anyway,
I ran the installer again and it got stuck apparently wanting this "thread272.dll"
so, I went to the directory it mentioned and there was a file there called that - and a couple of other files whose properties said it was tcl stuff,
so I researched tcl and found what seemed to be a trustworthy download.... moved the 3 files in the thread272 directory to a temporary folder and installed tcl


THEN Cool VL Viewer installed okay.
(despite there being NO thread272.dll in that original directory)

I'd been having some funny issues lately with running Steam & the Empyrion game - they kept moaning about DLL's too.
I am out of my depth with DLL's , so I looked everywhere for tips and did a few things and a few other obvious things, like updating all of my drivers, I had also removed a lot of software I don't really use, but avoided downloading any free DLL "fixer" progs because they are usually dangerous.

Anyway, Cool VL Viewer is running now, so I am a happy bunny again. (and I am not planning to use steam/empyrion for a while, so I'll keep an eye on them when I get round to that)

Minor point
I got a message "missing media_plugin_cef" message the first time cool loaded, but whatever that is - it didn't seem to be a show-stopper.
After sending a couple of IM's I quit and restarted cool and it seems fine now. (and no message about the media plugin)

Thanks once again for your help.


2019-08-04 19:43:37
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
You should not need to install Tcl, and the plugin issue is also a clear sign that things are still fishy on your system...

Try "sfc /scannow" from an elevated command prompt to try and repair your system.
If this fails, I would recommend that you backup your files and settings, and reinstall Windows from scratch to get rid of the virus/malware and restore missing DLLs.


2019-08-04 19:52:49
Profile WWW

Joined: 2016-05-26 00:41:06
Posts: 5
Reply with quote
Hi Henri,

Thank you VERY much.

Actually, I've been dreading you might say that, but I think I will have to bite the bullet and reinstall Windoze.
I thought I had resolved the issues with Steam & Empyrion at the time, but, as you say, perhaps something still festering away inside my system.
There is also the possibility I did more damage than good while trying to fix those issues, because I don't really understand anything to do with the registry or DLL's, but I did a lot of research at the time to see what I thought I could safely do.

I think I am now having problems with the viewer media playing in-world, but I haven't had time to work that out yet.
(I had picked up some flash subsitute that I think was recommended for firefox some time ago, but have forgotten the details now). I think I was pleased at the time that your viewer seemed to work well with it too.

That tcl thing seemed to be already installed on my system, but in its own directory, not the one giving the DLL "issues". In fact the fresh install didn't put any files there at all. It was simply the act of removing those files that seemed to 'cure' the problem.

Just run sfc, some corrupt files it can't fix. CBC log is MASSIVE and largely incomprehensible to me.

oh dear!

Ok,..... gotta get the glazier out & put in new windows.

Thanks for your kind help and patience! (and a GREAT viewer)

best regards,


2019-08-05 09:50:28
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 5 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.