Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2020-03-31 14:17:47



Reply to topic  [ 15 posts ]  Go to page 1, 2  Next
Talk/mic button doesn't light up when on? 
Author Message

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
Every so often, I get told that my mic is on, but the light on the button isn't. Usually when I'm using voice the talk button animates and changes color (I use the Silver skin) to tell it it's on, but during the times people tell me my mic is on, there is no light on or animation...? It's frustrating. Any idea how to fix this? ( I have no idea if it's on my end or something in the viewer or even a setting I'm over looking )

Cool VL Viewer v1.26.22.56, 64 bits, Aug 10 2019 12:15:13
RestrainedLove viewer v2.09.25.20
Release Notes

CPU: Intel(R) Core(TM) i7-4500U CPU @ 1.80GHz (2394.46 MHz)
Memory: 8076MB
OS version: Microsoft Windows 8.1 64 bits v6.2 (build 9200)
Memory manager: OS native
Graphics card vendor: Intel
Graphics card: Intel(R) HD Graphics 4400
Windows graphics driver version: Loading...
OpenGL version: 4.2.0 - Build 10.18.10.3345
Detected VRAM: 2112MB
J2C decoder: OpenJPEG: 1.4.0.635f
Audio driver: FMOD Studio v2.00.03
Networking backend: libcurl/7.47.0 OpenSSL/1.0.2l zlib/1.2.8
Embedded browser: CEF3 plugin v74.1.19+gb62bacf+chromium-74.0.3729.157

Built with: MSVC v1800
Compiler-generated maths: SSE2.

Compile flags used for this build:
/O2 /Oi /MD /MP /DNDEBUG /D_SECURE_SCL=0 /D_HAS_ITERATOR_DEBUGGING=0 /DWIN32 /D_WINDOWS /W3 /GR /EHsc /Oy- /GS /fp:fast /TP /W2 /Zc:forScope /Zc:wchar_t- /c /nologo /DLL_WINDOWS=1 /DUNICODE /D_UNICODE /DWINVER=0x0600 /D_WIN32_WINNT=0x0600 /DXML_STATIC /DBOOST_ALL_NO_LIB /DLL_LUA=1 /DLL_FMODSTUDIO=1 /DAPR_DECLARE_STATIC /DAPU_DECLARE_STATIC /DCURL_STATICLIB=1 /DLIB_NDOF=1


2019-08-24 15:23:08
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
I'd need the logs corresponding to the session when this issue happens, but I suspect an issue with your OS/driver sound mixer.


2019-08-26 19:44:45
Profile WWW

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
Any idea how to check that? On a Windows 8.1 system and on a Windows 10? Without having to get the logs? ( I will if absolutely necessary)
Thank You!


2019-08-27 20:57:22
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
You can check that the viewer does properly send the mic on/off commands via the log, by enabling the debug console ("Advanced" -> "Consoles" -> "Debug console") with the "Vivox" debug tag ("Advanced" -> "Consoles" -> "Debug tags") enabled/checked.

The log should show the following message when the mic is enabled:
Code:
DEBUG: LLVivoxProtocolParser::process_impl: Parsing: <Response requestId="NN" action="Connector.MuteLocalMic.1"><ReturnCode>0</ReturnCode><Results><StatusCode>0</StatusCode><StatusString /></Results><InputXml><Request requestId="NN" action="Connector.MuteLocalMic.1"><ConnectorHandle>xxxxxx</ConnectorHandle><Value>false</Value></Request></InputXml></Response>
(the important part being "<Value>false</Value>")

And when you disable the mic, it should show:
Code:
DEBUG: LLVivoxProtocolParser::process_impl: Parsing: <Response requestId="MM" action="Connector.MuteLocalMic.1"><ReturnCode>0</ReturnCode><Results><StatusCode>0</StatusCode><StatusString /></Results><InputXml><Request requestId="MM" action="Connector.MuteLocalMic.1"><ConnectorHandle>xxxxxx</ConnectorHandle><Value>true</Value></Request></InputXml></Response>
(i.e. the mute value changes for "true").

If you see this, and do not see spurious messages similar to the above when not switching the mic on/off yourself, then the viewer does properly its job and the rest (SLVoice.exe and mixer code) is not under its control...


2019-08-27 21:50:07
Profile WWW

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
ok Thank You... :) I'll let you know what I find... Migraine won't let me test this now... (I can't recreate this either, it just happens randomly).


2019-08-27 22:44:50
Profile

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
Ok here is the log file as it did it again... I hope I got the right file. Hard to read these things. I even set voice to Push to talk and until today, I thought I had it fixed. Any assistance on how I can fix this will be greatly appreciated. If I got the wrong file, please direct me. I got this from the CoolVL Viewer folder under where SL Stores it. Hope it helps. I tried fiddling with my sound mixer but am at a loss as to what to look for... Thanks again.

Also regarding the sound mixer doohickey, is there a place to find any logs there or info on where I can find where this happens on that? The mixer option on my laptop isn't really telling me much except that the volume is even across the devices...


Thanks so much....


Attachments:
File comment: I hope this is the right one
1eba5074-57f1-074a-26c7-7fe2c50ff34a.zip [29.6 KiB]
Downloaded 57 times
2019-09-22 23:20:49
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
This is not a log file, this is a decoded sound file from the viewer cache.

See this SL Wiki page for where to find the log files, depending on your OS. See also the Bug reporting forum rules that will give you more details about the log files naming.


2019-09-22 23:29:54
Profile WWW

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
Oops, sorry, here is the correct file...


Attachments:
CoolVLViewer.zip [18.62 KiB]
Downloaded 56 times
2019-09-30 17:59:00
Profile

Joined: 2009-03-17 18:42:51
Posts: 4180
Reply with quote
LadyJane wrote:
Oops, sorry, here is the correct file...

Nope, this is a crash dump file, and since I don't know what version of the viewer you are using, I cannot even use it to investigate the reason for the crash (which is always interesting for me, to fix those pesky crash bugs, even if it's not related with you mic problem here).

The log file ends with a '.log' extension, not a '.dmp' one.


2019-09-30 19:49:25
Profile WWW

Joined: 2016-08-19 23:21:40
Posts: 30
Reply with quote
I'll have to trim it as it says it is too big... (I completely forgot I have extensions hidden) Is there a specific section of the LOG that would be more important?
it will take me a few days to get this file shortened...


2019-10-02 22:16:30
Profile
Display posts from previous:  Sort by  
Reply to topic   [ 15 posts ]  Go to page 1, 2  Next

Who is online

Users browsing this forum: No registered users and 1 guest


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.