Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2021-12-07 19:16:03

Reply to topic  [ 3 posts ] 
[Solved] Crash when uploading images 
Author Message

Joined: 2010-04-30 23:14:32
Posts: 24
Reply with quote
Just recently, an odd thing started happening. I was on 2.08.02.something and yesterday installed, and it's still happening.
OPERATING ENVIRONMENT: Linux kernel 3.4.2, 8 GB RAM, AMD A6-3600 CPU, AMD Radeon HD-6530D.

The error:
2012-08-28T23:29:54Z INFO: processEOF: Rename failure (18) - /tmp/4fbad9ce-2a65-18f4-6f74-d39439486536.tmp to /home/gamer/.secondlife/cache_coolvlviewer/mute_169a55a9-6d4f-4e3b-bdf8-5676a769ddf9.tmp

This occurs when I attempt to upload an image file *just for one specific user*. If I log on to the same SL account while logged in to the system as root, or as my primary non-root user, I do not get the error. So I understand that this is a permissions problem and not specifically a Cool VL problem... but y'all know what is going on "under the hood" when you attempt to upload an image, and folks on my distro's support forum would not. So even if we can't fix the problem here, I can at least gather enough information to carry back to the Arch Linux guys.

The error occurs as soon as I click "Upload -> Image ($L10)", before any file dialogue appears.
Permissions for /tmp are 1777; I tried removing the sticky bit (0777) to see if that made a difference and it did not. Owner is root:root for /tmp, and in my distro the folder gets erased and rebuilt at each reboot.

I can go to /tmp as the problem user and create any files I want including /tmp/4fbad9ce-2a65-18f4-6f74-d39439486536.tmp from the above error, and I can then mv the file to /home/gamer/.secondlife/cache_coolvlviewer/mute_169a55a9-6d4f-4e3b-bdf8-5676a769ddf9.tmp without any error. So it's not folder permissions. I tried removing gamer's .secondlife folder in case there was a problem somewhere in the settings, but the same error occurs with default settings (and copying .secondlife to another user's folder, changing ownership and logging in as the new user works fine too).

Does that tmp file get created under a different user's name with different permissions during program execution? But then, why would my other non-root account be able to upload files without errors, but "gamer" can't? Neither of them is a member of the group root, so in theory they should both have the same permissions in /tmp/. Finally, I should mention that "gamer" was able to upload files in SL just fine up until a few weeks ago, and the errors started occurring without a change in Cool VL versions or kernel versions... or anything else that I am aware of.

Any suggestions on what else to test or where to look for the problem?

Last edited by SegmentationFault on 2012-08-29 17:32:26, edited 1 time in total.

2012-08-28 17:55:31

Joined: 2009-03-17 18:42:51
Posts: 4776
Reply with quote
and copying .secondlife to another user's folder, changing ownership and logging in as the new user works fine too
This is an administration problem (if you can upload from another, non-root account, then obviously, it's not related with the viewer).

Check the permissions of home/gamer, and if everything fails, at worst, you could delete the gamer account and recreate one.

Aside from that, I'm afraid I can't help you.

2012-08-28 18:23:04
Profile WWW

Joined: 2010-04-30 23:14:32
Posts: 24
Reply with quote
That was it exactly. I got hung up on thinking the problem was with /tmp rather than /home/gamer. When I renamed /home/gamer and created a new one from scratch, everything worked fine. I still have no idea what specifically the permission problem was, but it's resolved now.

2012-08-29 17:33:53
Display posts from previous:  Sort by  
Reply to topic   [ 3 posts ] 

Who is online

Users browsing this forum: No registered users and 1 guest

You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.