Cool VL Viewer forum

View unanswered posts | View active topics It is currently 2022-06-27 23:43:45



Reply to topic  [ 7 posts ] 
World map weirdness in CV 1.25 
Author Message

Joined: 2009-03-18 09:32:02
Posts: 246
Reply with quote
Hi,


the backported world map in the latest cool viewer 1.25 shows a kind of weird behaviour:

when it opens, and starts fetching map tiles, it fills the background not with the blue for water, but with a seemingly random map tile for who knows where, in high magnification.
Here's an example: Image - see the "normal" sim tiles to the left, and the huge one in the background...


didn't happen with the first version of that patch ;)

bye,
LC


2010-08-13 15:47:53
Profile YIM WWW

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
Please, provide the logs... See the forum rules about the necessary info to track down bugs.

I cannot reproduce your problem. A position on the grid from where you see this happening would be needed.

Also, did you try to:
1.- Clear your texture cache ?
2.- Uncheck the "Use Web Map Tiles" option in the Advanced menu and see if it still happens ?

Please, note that Snowglobe, on which the Cool VL Viewer v1.25 is based, still got *many* glitches, especially with texture fetching and caching (I just fixed a crash bug minutes ago)... This is why I still consider this viewer as experimental.


2010-08-13 20:05:17
Profile WWW

Joined: 2009-03-18 09:32:02
Posts: 246
Reply with quote
from the about box:

Cool VL Viewer 1.25.0 (0) Aug 8 2010 10:27:48 (Cool VL Viewer)
Versionshinweise

Built with GCC version 40102

CPU: Genuine Intel(R) CPU T2250 @ 1.73GHz
Memory: 2023 MB
OS Version: Linux 2.6.34-12-default #1 SMP 2010-06-29 02:39:08 +0200 i686
Graphics Card Vendor: NVIDIA Corporation
Graphics Card: GeForce 8400 GS/PCI/SSE2
OpenGL Version: 3.3.0 NVIDIA 256.35

libcurl Version: libcurl/7.16.4 OpenSSL/0.9.7c zlib/1.2.3.3 c-ares/1.4.0
J2C Decoder Version: KDU
Audio Driver Version: FMOD version 3.750000
Qt Webkit Version: 4.5.2


[*]it does not happen with official snowglobe 1.5.0.3610 from the sldev-commits email link
[*]it does seem to start when i zoom far out on the big map, using the scroll wheel on the mouse, while the map is still loading.
[*]clearing cache doesn't make a difference
[*]switching http map tiles on or off doesn't make a difference
[*]it doesn't happen in any specific location


Attachments:
File comment: log file. no stack trace since it doesn't crash.
mapweirdness.zip [19.62 KiB]
Downloaded 213 times
2010-08-13 21:11:37
Profile YIM WWW

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
The repro steps allowed me to reproduce the bug myself. Note that it does *not* happen if you disable the "Use Web Map Tiles" option in the Advanced menu *prior* to opening the map and zooming out (since in this case, the whole code behaves like with the v1.23 viewer map).

I also found and fixed the bug (it was due to a misunderstanding from my part on how multiple map blocks are layered and the continent low resolution background maps were not properly loaded as a result: these do not seem to exist anymore in Snowglobe and cannot be retrieved from the web).

The fix will be part of the next v1.25 release.


2010-08-13 22:24:42
Profile WWW

Joined: 2009-03-18 09:32:02
Posts: 246
Reply with quote
ok, i just told my wife that you got that fixed already...


Quote:
Oh my god that guy is bloody amazing.


2010-08-13 23:14:14
Profile YIM WWW

Joined: 2009-03-17 18:42:51
Posts: 4935
Reply with quote
V1.25.0.1 released with this bug fixed.


2010-08-14 18:54:11
Profile WWW

Joined: 2009-03-18 09:32:02
Posts: 246
Reply with quote
now my wife's repeating herself.. you are amazing.


2010-08-14 19:32:15
Profile YIM WWW
Display posts from previous:  Sort by  
Reply to topic   [ 7 posts ] 

Who is online

Users browsing this forum: No registered users and 0 guests


You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot post attachments in this forum

Search for:
Jump to:  
cron
Powered by phpBB® Forum Software © phpBB Group
Designed by ST Software.